Go Back  Ford Truck Enthusiasts Forums > Diesel > 1994.5 - 1997 7.3L Power Stroke Diesel
Reload this Page >

Could it be my TPS ? strange accelerator issues.

Notices
1994.5 - 1997 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

Could it be my TPS ? strange accelerator issues.

 
  #1  
Old 12-21-2015, 08:21 AM
Buck Dharma Fan
Buck Dharma Fan is offline
Senior User
Thread Starter
Join Date: Aug 2010
Location: Sound Beach L.I. N.Y
Posts: 204
Buck Dharma Fan is starting off with a positive reputation.
Could it be my TPS ? strange accelerator issues.

Hi All. In my otherwise excellent running 7.3. Sometimes I get almost no throttle response........In fact if I floor it, she may downshift and scoot one time. Then a minute later floor it again and get nothing ??? Sometimes it seems to bog and actually go slower. This is driving me nuts. It always runs smooth though..... just wont go any where sometimes. Any ideas ?
 
  #2  
Old 12-21-2015, 08:47 AM
z31freakify's Avatar
z31freakify
z31freakify is offline
Post Fiend
Join Date: Dec 2012
Location: Las Cruces New Mexico
Posts: 6,639
z31freakify is a splendid one to beholdz31freakify is a splendid one to beholdz31freakify is a splendid one to beholdz31freakify is a splendid one to beholdz31freakify is a splendid one to beholdz31freakify is a splendid one to beholdz31freakify is a splendid one to behold
Might be your APS (accelerator position sensor) or the AVS (the other seitch that tells that the pedal is being press) acting out, I forgot what the right ohm should be when testing, but they are so cheap that might as well buy a new one
 
  #3  
Old 12-21-2015, 10:03 AM
oldbird1965's Avatar
oldbird1965
oldbird1965 is offline
Post Fiend
Join Date: Aug 2004
Location: AZ
Posts: 19,409
oldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to behold
IVS, idle verification switch, might be bad. They are really hard to find. Get down there and when you push the pedal a little bit you should hear a click. Without that the computer stays in idle.
 
  #4  
Old 12-21-2015, 12:30 PM
fordpride's Avatar
fordpride
fordpride is offline
Post Fiend
Join Date: Dec 2009
Location: Livoina,La
Posts: 15,503
fordpride has a brilliant futurefordpride has a brilliant futurefordpride has a brilliant futurefordpride has a brilliant futurefordpride has a brilliant futurefordpride has a brilliant futurefordpride has a brilliant futurefordpride has a brilliant futurefordpride has a brilliant futurefordpride has a brilliant futurefordpride has a brilliant future
If the go pedal is responding then the ivs is good.

I'd start with checking the tin nut on the ipr
 
  #5  
Old 12-21-2015, 08:16 PM
oldbird1965's Avatar
oldbird1965
oldbird1965 is offline
Post Fiend
Join Date: Aug 2004
Location: AZ
Posts: 19,409
oldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to behold
I had a IVS that would stick once in awhile and it was no go, then go.
 
  #6  
Old 12-22-2015, 08:50 AM
Buck Dharma Fan
Buck Dharma Fan is offline
Senior User
Thread Starter
Join Date: Aug 2010
Location: Sound Beach L.I. N.Y
Posts: 204
Buck Dharma Fan is starting off with a positive reputation.
Thanks Boys ! Great info as usual. All I can confirm for now is that I do hear a click from the go pedal when I get down there. I'll look at the AVS and APS next. What about the tin nut on the IPR ? can you explain?
 
  #7  
Old 12-22-2015, 08:55 AM
oldbird1965's Avatar
oldbird1965
oldbird1965 is offline
Post Fiend
Join Date: Aug 2004
Location: AZ
Posts: 19,409
oldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to behold
What Mike means is there is a stupid tin nut on the back of the IPR that holds the solenoid on. It tends to come loose and then the IPR acts up.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dalesatter
1997-2006 Expedition & Navigator
91
01-03-2019 03:40 PM
jbrax
6.0L Power Stroke Diesel
33
04-15-2016 05:35 PM
Strokerboy73
1999 - 2003 7.3L Power Stroke Diesel
1
03-23-2016 04:04 PM
landscapeguy
6.0L Power Stroke Diesel
0
02-20-2016 08:28 PM
Strokerboy73
1999 - 2003 7.3L Power Stroke Diesel
6
12-03-2015 12:13 AM


Thread Tools
Search this Thread
Quick Reply: Could it be my TPS ? strange accelerator issues.


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: