Code P0170-Power Fuel Trim (Bank 1) - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Diesel > 6.7L Power Stroke Diesel
Reload this Page >

Code P0170-Power Fuel Trim (Bank 1)

Notices
6.7L Power Stroke Diesel 2011-current Ford Powerstroke 6.7 L turbo diesel engine
Sponsored by:
Sponsored by:

Code P0170-Power Fuel Trim (Bank 1)

 
  #1  
Old 12-10-2015, 08:47 PM
bkuuz1
bkuuz1 is offline
Elder User
Thread Starter
Join Date: Jul 2008
Location: Brighton CO.
Posts: 703
bkuuz1 is gaining momentum as a positive member of FTE.bkuuz1 is gaining momentum as a positive member of FTE.
Code P0170-Power Fuel Trim (Bank 1)

Hey guys,

Drove the truck to the store tonight about 5 minutes away and everything seemed fine. Went to leave the parking lot and noticed the check engine light was on. Pulled out my tablet, dongle and fired up Torque Pro. Retrieved error code P0170. Truck has a little over 12,700 miles and is complete stock. I ran a search and didn't come up with much info on this code other than what
Just Stroken posted in another post.

https://www.ford-trucks.com/forums/1...2015-6-7l.html


Anyone have any more information about this code?

Thanks in advanced.

Brice
 
  #2  
Old 03-13-2016, 06:29 PM
bkuuz1
bkuuz1 is offline
Elder User
Thread Starter
Join Date: Jul 2008
Location: Brighton CO.
Posts: 703
bkuuz1 is gaining momentum as a positive member of FTE.bkuuz1 is gaining momentum as a positive member of FTE.
Hello fellows,

Posting an update to the P0170 code.

I scheduled an appointment with my local ford dealer. Prior to dropping the truck off I noticed that when I was sitting at a stop light the truck had a slight shake to it and it seemed like the pinging was more pronounced. After a couple of days at the dealer they let me know that it was GTG.

When I picked up the truck, the service desk person said the diesel tech didn't find anything wrong. Which amazes me because when I dropped it off it had the check engine light on and again the P0170 code was displayed.

The service advisor then told me the tech reset the fuel system HIGH pressure side and reset Min. fuel mass adaptation all cylinders. When I asked if nothing was wrong then why the reset he said, "just to be sure."

After leaving the dealership, I noticed it seemed like the truck still had a louder then usual ping sound to it. After driving it for a few days I noticed the GPM was running way low. Not the 15 to 15.5 that I had before but in the low 10 to high 9 GPM. When I talked to the dealership again a couple of days later the response was because of the resets the truck would have to re-learn itself when being driven.

So after driving the truck for a couple of weeks to work and home, 18 mile round trip and mostly country roads with an average speed between 45 and 55 MPH, the miles per gallon is only reading 13ish.

So today after eating lunch, I went to remote start the truck when we were across the parking lot. Yep, got the horn beep and no remote start. After turning on the engine with the key, the engine light stayed on. After getting home and checking the codes, once again I have the P0170 code and now a P06EA (knock sensor) code to go along with it.

Here is a picture of the the service report they gave me when I picked up the truck.





Any thoughts?

Brice
 
  #3  
Old 03-14-2016, 02:00 PM
bkuuz1
bkuuz1 is offline
Elder User
Thread Starter
Join Date: Jul 2008
Location: Brighton CO.
Posts: 703
bkuuz1 is gaining momentum as a positive member of FTE.bkuuz1 is gaining momentum as a positive member of FTE.
Code P0170-Power Fuel Trim (Bank 1)

Anyone have any knowledge of this code issue?
 
  #4  
Old 03-15-2016, 07:09 PM
bkuuz1
bkuuz1 is offline
Elder User
Thread Starter
Join Date: Jul 2008
Location: Brighton CO.
Posts: 703
bkuuz1 is gaining momentum as a positive member of FTE.bkuuz1 is gaining momentum as a positive member of FTE.
Man, with over 900 views and no responses I must have the only truck with this issue.
 
  #5  
Old 03-16-2016, 06:37 PM
senix's Avatar
senix
senix is offline
Moderator
Join Date: Aug 2008
Location: Frederick, MD
Posts: 29,502
senix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputation
sounds like you need to go to a different dealer with a better tech. The knock sensor is a clue...or a intake leak. Something like that I believe.
 
  #6  
Old 03-16-2016, 08:05 PM
bkuuz1
bkuuz1 is offline
Elder User
Thread Starter
Join Date: Jul 2008
Location: Brighton CO.
Posts: 703
bkuuz1 is gaining momentum as a positive member of FTE.bkuuz1 is gaining momentum as a positive member of FTE.
Senix,

Any other ideas about the intake leak? I've looked over the engine and haven't found anything telling yet.

I've been trying to figure out a way to use the Torque Pro app. for now to check sensors. Hoping to get a chance to talk to the folks with Auto Ingenuity to see if I'll need updates for my program I was using on my 7.3.
 
  #7  
Old 03-16-2016, 08:09 PM
senix's Avatar
senix
senix is offline
Moderator
Join Date: Aug 2008
Location: Frederick, MD
Posts: 29,502
senix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputation
Yes,
you need to update it. They will also probably have the definition of the codes along with the new programming.


all you can do for now is find a different dealer with a better tech. You can check bolts and gaskets and make all looks tight.
 
  #8  
Old 03-16-2016, 08:11 PM
bkuuz1
bkuuz1 is offline
Elder User
Thread Starter
Join Date: Jul 2008
Location: Brighton CO.
Posts: 703
bkuuz1 is gaining momentum as a positive member of FTE.bkuuz1 is gaining momentum as a positive member of FTE.
Thanks seine.

I'll try that too.
 
  #9  
Old 03-16-2016, 08:14 PM
lhansman
lhansman is offline
Senior User
Join Date: Sep 2007
Location: Alton
Posts: 115
lhansman is starting off with a positive reputation.
You are not alone bkuuz1.

I have had this code pop up three trims in the last few weeks. I had my truck in for it's 56,000 kms service a few weeks ago and I don't know what they messed up at the dealer when changing filters but before I got the truck fifteen miles home the CEL light came on with some other fuel related code. The dealer actually sent the mechanic to see if they could sort the problem out on the side of the road and were unsuccessful so I wound up driving it back to them. I left it overnight and they told me the next day the replaced the fuel filter with another new one and that it was running fine.

I drive about 100 kms one way to work and the second or third day after that I got my first P0170 code and the CEL came on. I have the SCT tuner and so was able to read the code. My dealer is okay with the tuner but just in case they had to reprogram the truck I set it back to stock before leaving it with them - which of course cleared the code. They kept the truck for a day and could not replicate the problem.

I drove the truck for three or four days on stock tuning to see if it would pop up again and it did not so I put the tune back in as I prefer the performance and transmission shifting improvements. Again it was fine for a week or so and then I left on a 1,300 km trip up to James Bay. I stopped on the ice road at one point to commune with nature and when I got back in the truck the CEL was on again and the tuner told me it was P0170 again. I cleared the code and carried on.

I completed my journey and drove the 1,300 kms back plus a couple of days on my regular commute and it popped back up again. At this point, I just use the tuner to clear it as I don't notice any difference in performance after the code appears.

A private mechanic who does my non-warranty work thinks it could mean that an injector is going bad. I will be taking my truck in next week for its 64,000 km service. For the record my truck is a 2015 F350 dually built in April of 2015. This is the only anomaly I have had with this truck since new. It pulls my 16,000 pound fifth wheel or me 10 ton dumping trailer with ease and is the best damn truck I have ever had so I am not going to worry about it until Ford figures it out.

Regards,

Lauren
 
  #10  
Old 03-16-2016, 08:32 PM
bkuuz1
bkuuz1 is offline
Elder User
Thread Starter
Join Date: Jul 2008
Location: Brighton CO.
Posts: 703
bkuuz1 is gaining momentum as a positive member of FTE.bkuuz1 is gaining momentum as a positive member of FTE.
Thanks for the reply Lauren.

Originally, I had the P0170 code come up five or six times. Prior to this last time that was the only code. I had reset it before using my tab and Torque Pro app. This last time it lasted about a week or so after I got it back from the dealer before it popped it again along with the P06EA. The P06EA was second on the list so I assume it was the first in? When I drive the truck now it seems louder to me then before. I get a lot more pinging now when accelerating or cruising around 45 mph. This reoccurring issue has put a damper on the spring break trip for the family this year. I'm not really wanting to drag my toy hauler down the Grand Canyon next week just to get stuck on the side of the road.

The only issue I have had with my truck since buying it new was I had an exhaust TC blow out the day we brought or TH home. Other then that everything else had been good.

Brice
 
  #11  
Old 03-16-2016, 09:03 PM
lhansman
lhansman is offline
Senior User
Join Date: Sep 2007
Location: Alton
Posts: 115
lhansman is starting off with a positive reputation.
Hi bkuuz1

I still think the mechanic messed something up at my last service because I have had no issues with the truck since new until the last fuel filter change. I towed me 16,000 pound fifth wheel from Toronto to Key West over Christmas and New Years at 70 mph almost the whole way and she never missed a beat. With the cruise set at 70 on the hills through Tennessee, Kentucky and the Virginia's she shifted to fifth a few times but never lost any speed. These are awesome pulling machines.

I have pulled my dumping trailer loaded to around 20,000 pounds on a couple of trips but only 100 miles or so and the code never appeared. In fact, similar to my trip north to James Bay, twice the code has appeared after the truck had been idling for a few minutes (less than ten) and then as I accelerated away the CEL would come on. Perhaps I am lucky - or not sensitive enough - but I don't notice any change in the truck performance wise when the CEL comes on with this code. I can tell when she starts to regen though if I have missed the on screen display so I am not totally desensitised.

I am glad to hear the a couple of folks with stock trucks are experiencing this code because I was starting to wonder if it might be tuner related. I'm not letting it affect my use of the truck but then I am not heading far from home for a few weeks at this point.

Regards,

Lauren
 
  #12  
Old 05-05-2016, 11:45 AM
JonbF250
JonbF250 is offline
New User
Join Date: May 2016
Posts: 1
JonbF250 is starting off with a positive reputation.
any new information regarding this code? I have a f250 6.7 with 44k miles thanks
 
  #13  
Old 05-05-2016, 09:12 PM
JohnD333
JohnD333 is offline
Senior User
Join Date: Aug 2008
Posts: 442
JohnD333 has a good reputation on FTE.JohnD333 has a good reputation on FTE.JohnD333 has a good reputation on FTE.
Add me to the club. 36,400 miles. 2015 350 dually. Bone stock. Out of the blue...

Was scheduled to pick up load 1,250 miles from here tomorrow night.

Headed to dealer early AM.

Will report back.

Not happy...

Originally Posted by JonbF250 View Post
any new information regarding this code? I have a f250 6.7 with 44k miles thanks
 
  #14  
Old 05-06-2016, 06:40 AM
lhansman
lhansman is offline
Senior User
Join Date: Sep 2007
Location: Alton
Posts: 115
lhansman is starting off with a positive reputation.
I continue to see this code pop up at least once a week. On my 2015 it always appears after a 5 - 15 minute period of idling and then I pull away and the CEL illuminates. It has never happened while driving down the road and I have put around 12,000 kms on my truck since it first appeared. I removed the tuner for a week or so and could not get the code to appear so I reinstalled the tune. Fortunately with the tuner I can clear the codes on the fly which turns off the CEL so that's what I did now when it appears. So far no ill effects.

Regards,

Lauren
 
  #15  
Old 05-06-2016, 07:03 AM
JohnD333
JohnD333 is offline
Senior User
Join Date: Aug 2008
Posts: 442
JohnD333 has a good reputation on FTE.JohnD333 has a good reputation on FTE.JohnD333 has a good reputation on FTE.
New info courtesy to autocodes.com - may help others:

AutoCodes* OBDII Code List* P0170
P0170 - Fuel Trim Malfunction Bank 1

Repair Importance Level:*3/3
Repair Difficulty Level:*3/3*
Possible causes
- Intake air leaks
- Faulty front heated oxygen sensor
- Ignition misfiring
- Faulty fuel injectors
- Exhaust gas leaks
- Incorrect fuel pressure
- Lack of fuel
- Faulty Mass Air Flow (MAF) sensor
- Incorrect Positive Crankcase Ventilation (PCV) hose connection
What does this mean?
Tech notes
Dirty air filter, air filter housing or Mass Air Flow (MAF) sensor, or faulty MAF sensor are common causes for the P0170 code.
What does this mean?
When is the code detected?
Fuel injection system does not operate properly or the amount of mixture ratio compensation is not correct


Read more: P0170 Fuel Trim Malfunction Bank 1 | AutoCodes
 

Thread Tools
Search this Thread
Quick Reply: Code P0170-Power Fuel Trim (Bank 1)


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: