2007 expedition front a/c not working - Ford Truck Enthusiasts Forums

Notices
2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

2007 expedition front a/c not working

Reply

 
 
 
  #1  
Old 08-27-2015, 08:41 AM
Allen Baragar
Allen Baragar is offline
New User
Thread Starter
Join Date: Aug 2015
Posts: 1
Allen Baragar is starting off with a positive reputation.
2007 expedition front a/c not working

My 2007 expedition XLT EL front a/c is working intermittently. For instance, I got in it this morning and it was working. Within 2 minutes it stopped. None of the controls work, so changing from max to low, it still will not blow. The rear a/c still works and blows cold air.

I am thinking that it is the blower motor, but looking for suggestions. I do not want to take it to the dealership if at all possible.

Thanks in advance.
 
Reply With Quote
  #2  
Old 08-07-2018, 01:16 AM
parkercouple's Avatar
parkercouple
parkercouple is offline
Freshman User
Join Date: Nov 2008
Posts: 28
parkercouple is starting off with a positive reputation.
Originally Posted by Allen Baragar View Post
My 2007 expedition XLT EL front a/c is working intermittently. For instance, I got in it this morning and it was working. Within 2 minutes it stopped. None of the controls work, so changing from max to low, it still will not blow. The rear a/c still works and blows cold air.

I am thinking that it is the blower motor, but looking for suggestions. I do not want to take it to the dealership if at all possible.

Thanks in advance.
What ended up being the problem I have a 2007 as well and every so often mine does the same thing. I can feel the cold just not blowing until I turn it off and back on
 
Reply With Quote
  #3  
Old 09-11-2018, 07:24 PM
dalesatter's Avatar
dalesatter
dalesatter is offline
Junior User
Join Date: Jun 2007
Location: HOUSTON, TX
Posts: 84
dalesatter is starting off with a positive reputation.
My 2007 started to do the exact same thing about a week ago, except its not coming on after turning it off anymore. Anyone have a solution?
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
eddieniner
1997-2006 Expedition & Navigator
2
05-14-2016 11:00 AM
BTKillerr
Escape & Escape Hybrid
0
08-28-2015 06:04 PM
Bloody-J
2007 - 2014 Expedition & Navigator
4
08-12-2015 10:33 PM
5504x4drwcrew
6.0L Power Stroke Diesel
15
10-16-2011 09:42 PM
BriR
1997-2006 Expedition & Navigator
2
07-11-2008 08:20 AM


Thread Tools
Search this Thread
Quick Reply: 2007 expedition front a/c not working


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: