Very high idling... after cleaning iac - Ford Truck Enthusiasts Forums

Notices
1987 - 1996 F150 & Larger F-Series Trucks 1987 - 1996 Ford F-150, F-250, F-350 and larger pickups - including the 1997 heavy-duty F250/F350+ trucks

Very high idling... after cleaning iac

Reply

 
 
 
  #1  
Old 07-22-2015, 04:36 PM
Jonathan Stone
Jonathan Stone is offline
New User
Thread Starter
Join Date: Jul 2015
Posts: 24
Jonathan Stone is starting off with a positive reputation.
Very high idling... after cleaning iac

I have a 1994 F150 with dual tanks 4x4 5.0 and I cleaned the IAC valve due to other issues going on which that helped 100% but now my truck is idling at 1500 rpms. I haven't really run it much so could it be that my computer needs to reset itself? Maybe I should unplug iac? I also heard something about too much air getting in the holes in the tps on the butterflys? Should I take off the tps and clean it? Any help would be great.
 
Reply With Quote
  #2  
Old 07-22-2015, 08:39 PM
kermmydog's Avatar
kermmydog
kermmydog is offline
Post Fiend
Join Date: Oct 2003
Location: Western Central NV
Posts: 9,173
kermmydog has a spectacular reputation.kermmydog has a spectacular reputation.kermmydog has a spectacular reputation.kermmydog has a spectacular reputation.kermmydog has a spectacular reputation.kermmydog has a spectacular reputation.kermmydog has a spectacular reputation.kermmydog has a spectacular reputation.kermmydog has a spectacular reputation.kermmydog has a spectacular reputation.kermmydog has a spectacular reputation.
Try resetting the computer, You won't hurt anything cleaning the TPS.
 
Reply With Quote
  #3  
Old 07-22-2015, 09:03 PM
wtroger
wtroger is offline
Postmaster
Join Date: May 2001
Posts: 2,975
wtroger is gaining momentum as a positive member of FTE.wtroger is gaining momentum as a positive member of FTE.
It is stuck open try again
 
Reply With Quote
  #4  
Old 07-23-2015, 06:49 AM
dixie460's Avatar
dixie460
dixie460 is offline
Postmaster
Join Date: Nov 2011
Location: SW Florida
Posts: 3,505
dixie460 has a very good reputation on FTE.dixie460 has a very good reputation on FTE.dixie460 has a very good reputation on FTE.
Stuck open or you lost/damaged the gasket between the IAC valve and throttle body. Or otherwise have a vacuum leak somewhere (did you disconnect any vacuum lines?)
 
Reply With Quote
  #5  
Old 08-24-2016, 04:11 PM
TimB-
TimB- is offline
New User
Join Date: Aug 2016
Posts: 6
TimB- is starting off with a positive reputation.
Might be the spacer plate between the IAC and throttle body. I have a 1990 5.0 F150 and changed the IAC and had high Idle, it was 2000 - 1500 because the spacer plate was put on backwards, on the 5.0 the plate has holes on one edge, and the holes should face forward on mine, so that the side holes feed the large incoming port to the IAC and not the small out going IAC port on the TB. You might check yours or try it the other way, incase its flipped.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Ionlydrivefords
1987 - 1996 F150 & Larger F-Series Trucks
0
10-21-2017 07:38 PM
dstrahm
Aerostar
6
11-19-2016 10:33 PM
Anthonynoble
1987 - 1996 F150 & Larger F-Series Trucks
14
08-24-2016 04:13 PM
troubled1
1987 - 1996 F150 & Larger F-Series Trucks
15
08-24-2016 04:12 PM
Jonathan Stone
General Automotive Discussion
2
08-24-2016 04:10 PM


Thread Tools
Search this Thread
Quick Reply: Very high idling... after cleaning iac


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.