Notices
1999 - 2003 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

My new 7.3 is a dog need help

 
  #1  
Old 12-20-2014, 07:40 PM
savagebagz
savagebagz is offline
Junior User
Thread Starter
Join Date: Dec 2014
Posts: 54
savagebagz is starting off with a positive reputation.
My new 7.3 is a dog need help

Ok so I have a 2000 7.3 all stock It is very weak compared to my other 2000 7.3 and my old 99 7.3 that I used to have (RIP)

When I purchased it I thought it was just boost leaks that I could fix But after checking it I make

17psi boost wot

There is no blow by

I've done all the fluid and filter changes

It feels pretty good at 1/2 throttle or less, however at wot it's a dog and struggles getting from 55-65mph

Also over 2000rpm/half throttle there is a weird fluttering air sound (also why I thought I had boost leaks yet I'm making good boost) and that's when the power falls on it's face and struggles to hit 3k rpm.

Another thing I noticed after I purchased this truck is that the engine is very quiet I can barely hear it in the cab. Sounds more like a gasser not that loud knocking sound of my other 7.3.

Only codes I get are 2 bad glow plugs which would explain my white smoke on cold starts. (No smoke when warm)

Should I sell this thing or can I fix it up?
 
  #2  
Old 12-20-2014, 07:57 PM
Tugly's Avatar
Tugly
Tugly is offline
Post Fiend
Join Date: Jan 2011
Location: Columbia River
Posts: 18,347
Tugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputation
It sounds like low ICP to me. Have you tried disconnecting the ICP sensor connector and going for a drive?
 
  #3  
Old 12-20-2014, 07:57 PM
M-S-G
M-S-G is offline
Senior User
Join Date: Nov 2014
Posts: 432
M-S-G is gaining momentum as a positive member of FTE.M-S-G is gaining momentum as a positive member of FTE.
Check out 'Turbo Surge' on youtube and tell is if that's what you hear.
 
  #4  
Old 12-20-2014, 08:14 PM
savagebagz
savagebagz is offline
Junior User
Thread Starter
Join Date: Dec 2014
Posts: 54
savagebagz is starting off with a positive reputation.
Originally Posted by M-S-G View Post
Check out 'Turbo Surge' on youtube and tell is if that's what you hear.
It sounds very similar except mine doesn't chirp it's all fluttering air sound
Also my boost doesn't fluctuate when this happens it will hold 16/17 psi
 
  #5  
Old 12-20-2014, 08:15 PM
savagebagz
savagebagz is offline
Junior User
Thread Starter
Join Date: Dec 2014
Posts: 54
savagebagz is starting off with a positive reputation.
Originally Posted by Tugly View Post
It sounds like low ICP to me. Have you tried disconnecting the ICP sensor connector and going for a drive?
I havnt yet I will try that tomorrow
 
  #6  
Old 12-20-2014, 08:29 PM
M-S-G
M-S-G is offline
Senior User
Join Date: Nov 2014
Posts: 432
M-S-G is gaining momentum as a positive member of FTE.M-S-G is gaining momentum as a positive member of FTE.
Originally Posted by savagebagz View Post
It sounds very similar except mine doesn't chirp it's all fluttering air sound Also my boost doesn't fluctuate when this happens it will hold 16/17 psi
My money is on ICP then. Mine failed too.
 
  #7  
Old 12-21-2014, 07:06 AM
savagebagz
savagebagz is offline
Junior User
Thread Starter
Join Date: Dec 2014
Posts: 54
savagebagz is starting off with a positive reputation.
Originally Posted by savagebagz View Post
I havnt yet I will try that tomorrow
Ok so I unplugged my icp sensor and lots of oil in the connector.
I went on a drive and my bottom end power was even worse with a super delayed turbo spool , top end same symptoms..
Still can barely hit 3k rpm while my other truck slaps the red line after turbo spools.

I also crawled underneath with a flashlight and can see the infamous black soot on my up pipe collector, passenger side.
 
  #8  
Old 12-21-2014, 07:09 AM
savagebagz
savagebagz is offline
Junior User
Thread Starter
Join Date: Dec 2014
Posts: 54
savagebagz is starting off with a positive reputation.
I thought I was getting a good deal for this 00' excursion with 170k miles for 8 grand, but I'm starting to think I got shafted.
 
  #9  
Old 12-21-2014, 08:47 AM
HD Rider's Avatar
HD Rider
HD Rider is offline
Posting Guru
Join Date: Aug 2009
Location: Glendive, MT
Posts: 1,988
HD Rider is a name known to allHD Rider is a name known to allHD Rider is a name known to allHD Rider is a name known to allHD Rider is a name known to allHD Rider is a name known to all
You didn't get shafted. Sounds like it just needs some TLC.
 
  #10  
Old 12-21-2014, 09:35 AM
Tugly's Avatar
Tugly
Tugly is offline
Post Fiend
Join Date: Jan 2011
Location: Columbia River
Posts: 18,347
Tugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputation
8 grand? They go for at least twice that here - even with an exhaust leak.
 
  #11  
Old 12-21-2014, 11:36 AM
M-S-G
M-S-G is offline
Senior User
Join Date: Nov 2014
Posts: 432
M-S-G is gaining momentum as a positive member of FTE.M-S-G is gaining momentum as a positive member of FTE.
Originally Posted by savagebagz View Post
Ok so I unplugged my icp sensor and lots of oil in the connector. I went on a drive and my bottom end power was even worse with a super delayed turbo spool , top end same symptoms.. Still can barely hit 3k rpm while my other truck slaps the red line after turbo spools. I also crawled underneath with a flashlight and can see the infamous black soot on my up pipe collector, passenger side.
Replace icp. Available in your local autozone.
If you have oil in it it's shot and will let you stranded.
 
  #12  
Old 12-21-2014, 01:38 PM
FiznUKa's Avatar
FiznUKa
FiznUKa is offline
Posting Guru
Join Date: Mar 2014
Location: Salt Lake City, utah
Posts: 1,460
FiznUKa has a very good reputation on FTE.FiznUKa has a very good reputation on FTE.FiznUKa has a very good reputation on FTE.FiznUKa has a very good reputation on FTE.
Originally Posted by M-S-G View Post
Replace icp. Available in your local autozone.
If you have oil in it it's shot and will let you stranded.

Use only OEM sensors or you will be back down this road again.
 
  #13  
Old 12-21-2014, 01:49 PM
mechelement's Avatar
mechelement
mechelement is offline
Postmaster
Join Date: Oct 2008
Location: Eaton, CO
Posts: 3,250
mechelement has a good reputation on FTE.mechelement has a good reputation on FTE.mechelement has a good reputation on FTE.
To me it sounds like a fuel supply issue. An oily sensor couldn't help.
 
  #14  
Old 12-21-2014, 01:57 PM
Bonanza35
Bonanza35 is offline
Post Fiend
Join Date: Sep 2005
Location: Norco,CA
Posts: 7,987
Bonanza35 is a splendid one to beholdBonanza35 is a splendid one to beholdBonanza35 is a splendid one to beholdBonanza35 is a splendid one to beholdBonanza35 is a splendid one to beholdBonanza35 is a splendid one to beholdBonanza35 is a splendid one to beholdBonanza35 is a splendid one to behold
You need to be able to read your sensors. Can you read HPOP and duty cycle's? Also can you read fuel pressure? Sounds like you got a good deal on the EX. Where are you at? Maybe one of the brothers here can help.
 
  #15  
Old 12-21-2014, 02:09 PM
savagebagz
savagebagz is offline
Junior User
Thread Starter
Join Date: Dec 2014
Posts: 54
savagebagz is starting off with a positive reputation.
I will be ordering an icp sensor today. ( motorcraft) Should I order a new connector with it?

I also have to order something to monitor fuel pressure because I have no way of doing that.

I do remember the previous owner mentioning that he installed a new fuel pump. Maybe he tried to fix this problem and gave up and passed it to me on the cheap.
 

Thread Tools
Search this Thread
Quick Reply: My new 7.3 is a dog need help


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.