'07 Expedition cranks, won't turn says low oil pressure - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

'07 Expedition cranks, won't turn says low oil pressure

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-29-2014, 02:31 PM
Michael Sharpe Michael Sharpe is offline
New User
Thread Starter
 
Join Date: Jun 2014
Posts: 2
Michael Sharpe is starting off with a positive reputation.
'07 Expedition cranks, won't turn says low oil pressure

I have a 07 Expedition that will not start. I went out one morning it started I backed up and then the engine shut itself off. It did not sputter and die, it turned off. I turned the key and it cranks normally but for about 10 seconds on one turn. Then the oil light came on. I went through many forums and the best I could come up with is oil sending unit is bad. Replaced it, changed the oil and the filter yet it still does the same thing. It was making no noises and the pressure had never fluctuated previously. The gauge will read pressure while cranking then drop to nothing when it is done cranking and the oil light comes on along with the check engine light. Does anyone have any idea what it could be or solutions? Thank you for any future help.
Reply With Quote
  #2  
Old 06-29-2014, 02:59 PM
Michael Sharpe Michael Sharpe is offline
New User
Thread Starter
 
Join Date: Jun 2014
Posts: 2
Michael Sharpe is starting off with a positive reputation.
I disconnected the battery to see if the computer reset that would fix the issue since I just installed a new oil pressure sensor. However it did not fix it still does the same thing, however now the CEL blinks at me instead of staying solid.
Reply With Quote
  #3  
Old 07-01-2014, 10:45 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,133
berry1234 is gaining momentum as a positive member of FTE.
Time to take it in. Throwing parts at a fix is expensive and rarely fixes the issue. Need someone with experience with mod motors.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2006 Expedition random crank but no start hjwalker 2004 - 2008 F150 3 04-23-2017 10:18 AM
1995 7.3 Powerstroke Not Starting 0500757Arf 1987 - 1996 F150 & Larger F-Series Trucks 42 04-20-2017 07:19 PM
2002 F-150 Won't turn over lblackwood82 1997 - 2003 F150 6 09-10-2016 07:03 AM
2004 Expedition XLT Shutting Off w/ Low Oil Pressure Light On mcbridec 1997-2006 Expedition & Navigator 6 10-31-2013 11:18 AM
'05 6.0 wont start at running temp? Daniel L. 6.0L Power Stroke Diesel 10 04-13-2012 10:26 AM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 05:39 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: