Notices
1987 - 1996 F150 & Larger F-Series Trucks 1987 - 1996 Ford F-150, F-250, F-350 and larger pickups - including the 1997 heavy-duty F250/F350+ trucks

Speedo cable twitching, new cable, lubed with supplied grease

 
  #1  
Old 05-02-2013, 06:25 AM
Hutch17's Avatar
Hutch17
Hutch17 is offline
Elder User
Thread Starter
Join Date: Aug 2012
Posts: 508
Hutch17 is starting off with a positive reputation.
Speedo cable twitching, new cable, lubed with supplied grease

Hey gents,
I recently got a new speedo cable for my truck and installed it yesterday. After I put it in I drove it up the road to see if it worked. Well it dosent register until your going atleast 30 and it says your going 15ish. It jumps around a lot at all speeds. At 50-60 its around 25ish. I lubed it with the supplied grease. Can anyone tell me how to fix this? I need this working asap
 
  #2  
Old 05-03-2013, 05:31 AM
Hutch17's Avatar
Hutch17
Hutch17 is offline
Elder User
Thread Starter
Join Date: Aug 2012
Posts: 508
Hutch17 is starting off with a positive reputation.
Bump, any help is appreciated!
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
hairyboxnoogle
1973 - 1979 F-100 & Larger F-Series Trucks
4
07-09-2012 09:49 PM
steveh
1967 - 1972 F-100 & Larger F-Series Trucks
1
09-20-2009 10:38 PM
BuffDaddy
Oil & Lubrication
9
03-23-2006 10:58 AM
JimmyRC86F150
1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks
1
02-27-2006 05:09 AM
Oceanwave
Bronco II
2
05-20-2003 08:53 PM


Thread Tools
Search this Thread
Quick Reply: Speedo cable twitching, new cable, lubed with supplied grease


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.