Turn signal/brake lights don't work - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Misc. > Electrical Systems/Wiring
Reload this Page >

Turn signal/brake lights don't work

Notices

Turn signal/brake lights don't work

Reply

 
 
 
  #1  
Old 04-02-2013, 10:03 PM
Carolina Sorillo
Carolina Sorillo is offline
New User
Thread Starter
Join Date: Nov 2010
Posts: 7
Carolina Sorillo is starting off with a positive reputation.
Turn signal/brake lights don't work

This is on a '99 F250 extended cab, 7.3, 6 speed. It was used by a local steel fabricator, who made the flatbed that's on it. It appears their "resident electrician" wired the lights! I really can't explain the wad of wire, tape and wire connectors that was back there. I should've taken pictures before removing most of it. Anyway, it was all working fine until a couple weeks ago. The right rear blinker stopped working. I switched the bulb with right and no change. So I figure, it's not the bulb. So I start untaping the wires. I find wires just twisted together and taped or some little blue "boxes" that use a piece of metal to cut through insulation of the two wires to make the connection. Long story short, I cut out all the unnecessary junctions while keeping the wires still running where they were. Now, both blinkers blink really fast and brake lights work... until I turn on the headlights. Then no turn signals or brake lights!! There is a grey plastic plug in the wiring harness with 6 wires going in and 6 wires coming out, all this is behind the grey plug. There are also 2 of the 6 wires coming out of the plug not used.

C.S.
 
Reply With Quote
  #2  
Old 05-14-2015, 08:29 AM
Patrick1982
Patrick1982 is offline
New User
Join Date: May 2015
Posts: 4
Patrick1982 is starting off with a positive reputation.
Did you check your fuses and bulbs first?
 
Reply With Quote
  #3  
Old 05-14-2015, 10:30 AM
Franklin2's Avatar
Franklin2
Franklin2 is online now
Moderator
Join Date: Jan 2001
Location: New Market, VA
Posts: 41,512
Franklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant future
Originally Posted by Carolina Sorillo View Post
This is on a '99 F250 extended cab, 7.3, 6 speed. It was used by a local steel fabricator, who made the flatbed that's on it. It appears their "resident electrician" wired the lights! I really can't explain the wad of wire, tape and wire connectors that was back there. I should've taken pictures before removing most of it. Anyway, it was all working fine until a couple weeks ago. The right rear blinker stopped working. I switched the bulb with right and no change. So I figure, it's not the bulb. So I start untaping the wires. I find wires just twisted together and taped or some little blue "boxes" that use a piece of metal to cut through insulation of the two wires to make the connection. Long story short, I cut out all the unnecessary junctions while keeping the wires still running where they were. Now, both blinkers blink really fast and brake lights work... until I turn on the headlights. Then no turn signals or brake lights!! There is a grey plastic plug in the wiring harness with 6 wires going in and 6 wires coming out, all this is behind the grey plug. There are also 2 of the 6 wires coming out of the plug not used.

C.S.
You need to make sure the lights are grounded. If the lights in the bed have a ground wire, run it to the frame and that should help part of your problems.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
littleredford69
Other; Brakes, Electrical, Hitches, Weight Distribution & CDL Discussion
4
02-27-2016 01:13 PM
miihere24
1967 - 1972 F-100 & Larger F-Series Trucks
44
01-14-2016 12:32 PM
TgupLou59
1957 - 1960 F100 & Larger F-Series Trucks
10
04-02-2014 09:18 PM
dwildey
1967 - 1972 F-100 & Larger F-Series Trucks
10
04-19-2010 06:19 AM
boggerted
1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks
2
09-23-2008 09:27 PM


Thread Tools
Search this Thread
Quick Reply: Turn signal/brake lights don't work


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.