Turn signal/brake lights don't work - Ford Truck Enthusiasts Forums



Turn signal/brake lights don't work

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-02-2013, 11:03 PM
Carolina Sorillo Carolina Sorillo is offline
New User
Thread Starter
 
Join Date: Nov 2010
Posts: 7
Carolina Sorillo is starting off with a positive reputation.
Turn signal/brake lights don't work

This is on a '99 F250 extended cab, 7.3, 6 speed. It was used by a local steel fabricator, who made the flatbed that's on it. It appears their "resident electrician" wired the lights! I really can't explain the wad of wire, tape and wire connectors that was back there. I should've taken pictures before removing most of it. Anyway, it was all working fine until a couple weeks ago. The right rear blinker stopped working. I switched the bulb with right and no change. So I figure, it's not the bulb. So I start untaping the wires. I find wires just twisted together and taped or some little blue "boxes" that use a piece of metal to cut through insulation of the two wires to make the connection. Long story short, I cut out all the unnecessary junctions while keeping the wires still running where they were. Now, both blinkers blink really fast and brake lights work... until I turn on the headlights. Then no turn signals or brake lights!! There is a grey plastic plug in the wiring harness with 6 wires going in and 6 wires coming out, all this is behind the grey plug. There are also 2 of the 6 wires coming out of the plug not used.

C.S.
Reply With Quote
  #2  
Old 05-14-2015, 09:29 AM
Patrick1982 Patrick1982 is offline
New User
 
Join Date: May 2015
Posts: 4
Patrick1982 is starting off with a positive reputation.
Did you check your fuses and bulbs first?
Reply With Quote
  #3  
Old 05-14-2015, 11:30 AM
Franklin2's Avatar
Franklin2 Franklin2 is offline
Moderator
 
Join Date: Jan 2001
Location: New Market, VA
Posts: 40,491
Franklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant future
Quote:
Originally Posted by Carolina Sorillo View Post
This is on a '99 F250 extended cab, 7.3, 6 speed. It was used by a local steel fabricator, who made the flatbed that's on it. It appears their "resident electrician" wired the lights! I really can't explain the wad of wire, tape and wire connectors that was back there. I should've taken pictures before removing most of it. Anyway, it was all working fine until a couple weeks ago. The right rear blinker stopped working. I switched the bulb with right and no change. So I figure, it's not the bulb. So I start untaping the wires. I find wires just twisted together and taped or some little blue "boxes" that use a piece of metal to cut through insulation of the two wires to make the connection. Long story short, I cut out all the unnecessary junctions while keeping the wires still running where they were. Now, both blinkers blink really fast and brake lights work... until I turn on the headlights. Then no turn signals or brake lights!! There is a grey plastic plug in the wiring harness with 6 wires going in and 6 wires coming out, all this is behind the grey plug. There are also 2 of the 6 wires coming out of the plug not used.

C.S.
You need to make sure the lights are grounded. If the lights in the bed have a ground wire, run it to the frame and that should help part of your problems.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
BRAKE LIGHTS littleredford69 Other; Brakes, Electrical, Hitches, Weight Distribution & CDL Discussion 4 02-27-2016 02:13 PM
Let there be light... miihere24 1967 - 1972 F-100 & Larger F-Series Trucks 44 01-14-2016 01:32 PM
1959 Ford F100 Driver side brake light not working?!? TgupLou59 1957 - 1960 F100 & Larger F-Series Trucks 10 04-02-2014 10:18 PM
FIXED: Weird Turn Signal Problem - Any ideas? No Harzards/Brakes Now! dwildey 1967 - 1972 F-100 & Larger F-Series Trucks 10 04-19-2010 07:19 AM
brake and blinker lights don't work boggerted 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 2 09-23-2008 10:27 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 06:48 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.