Start and Stall, Problem Water Separator - Ford Truck Enthusiasts Forums



Virginia Chapter Join Chapter, Leader:

Start and Stall, Problem Water Separator

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-22-2012, 09:21 AM
Dieselamour's Avatar
Dieselamour Dieselamour is offline
Elder User
Thread Starter
 
Join Date: Jun 2007
Location: Virginia
Posts: 820
Dieselamour has a good reputation on FTE.Dieselamour has a good reputation on FTE.Dieselamour has a good reputation on FTE.
Start and Stall, Problem Water Separator

Hey all....

FYI - I just thought I would post this. This started recently and immediately. I would start the ol' girl (6.9) and and she'd run for a minute or two and stall. During the run time she sounded as if there was air in the fuel, not smooth and a bit rough and light. I began to think it was my pick up tubes in the tank but it was occurring on both tanks, even when full, so I decided to check my water separator first. I removed the separator from the circuit and put a clear filter in its place where I could monitor fuel supply and quality during this time.

The water separator was indeed the problem as it was letting air into the fuel line. I got the present separator from a fellow member years ago and it was a crap-shoot on how long it would last, but I cleaned it up and replaced some seals before installing it. Anyway, I'm going to put a new separator in the circuit, but they are discontinued.

Have a great day and thanks for reading.
Reply With Quote
  #2  
Old 07-23-2012, 04:00 PM
archtaan's Avatar
archtaan archtaan is offline
Post Fiend
 
Join Date: Feb 2011
Location: Virginia
Posts: 29,909
archtaan has a superb reputationarchtaan has a superb reputationarchtaan has a superb reputationarchtaan has a superb reputationarchtaan has a superb reputationarchtaan has a superb reputationarchtaan has a superb reputationarchtaan has a superb reputationarchtaan has a superb reputationarchtaan has a superb reputationarchtaan has a superb reputation
Is this a 6.0 or a 7.3?

The frame mounted one on the 6.0 is a know problem with a cheap fix from some of the online vendors. Not sure about the 7.3's though.

Glad you figured it out quick!
Reply With Quote
  #3  
Old 07-30-2012, 06:44 PM
Dieselamour's Avatar
Dieselamour Dieselamour is offline
Elder User
Thread Starter
 
Join Date: Jun 2007
Location: Virginia
Posts: 820
Dieselamour has a good reputation on FTE.Dieselamour has a good reputation on FTE.Dieselamour has a good reputation on FTE.
6.9, sorry
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
water in fuel delima john johns Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 3 09-24-2016 08:24 AM
Starts, Runs and Dies only on rear tank. darryl97420 Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 3 12-26-2014 10:20 PM
2001 Escape - stall after fueling 1egg1basket Escape & Escape Hybrid 38 12-03-2013 12:35 PM
7.3 Water Seperator Leak eatont9999 Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 51 08-17-2012 09:55 AM
7.3 fuel filter to 6.9? 86.9 Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 8 04-22-2010 09:25 AM


Go Back   Ford Truck Enthusiasts Forums > >

Tags
rough idle, stall, start, water

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 01:56 PM.