Back up camera display acting up, not coming on or staying on - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Back up camera display acting up, not coming on or staying on

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-07-2012, 05:16 PM
txcitycyclesales txcitycyclesales is offline
New User
Thread Starter
 
Join Date: Apr 2004
Location: Texas City, TX
Posts: 3
txcitycyclesales is starting off with a positive reputation.
Back up camera display acting up, not coming on or staying on

The reverse camera display on my wife's 2010 Eddie Bauer Expedition is acting up. She has the factory Nav in the dash. Some times the camera does not display and sometimes it stays on even after shiffting into drive. I figure there must be some kind of sensor for the shifter mechanism. But I figured surely someone has had the problem. I did a search but did not see and answer. Please let me know if you have already figured yours out. Thanks.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
back up camera for 2012 escape rickfar Escape & Escape Hybrid 0 08-30-2014 06:40 PM
2014 backup camera smoky_diesel 6.7L Power Stroke Diesel 9 01-13-2014 03:23 PM
Additional Camera Fontana 6.7L Power Stroke Diesel 5 08-10-2012 01:44 PM
back up camera not working honeyb Excursion - King of SUVs 2 08-13-2009 07:23 PM
Camera to replace rearview mirror...? Drawsoncad420 1997-2006 Expedition & Navigator 4 07-15-2002 08:04 AM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2004, 2007, add, article, back, backup, camera, car, dashboard, eb, expedition, ford, mechanism, navigator, powered

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 02:39 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send