03 Expedition Water around the spark plugs! - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

03 Expedition Water around the spark plugs!

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-02-2012, 11:47 PM
lilmac556 lilmac556 is offline
New User
Thread Starter
 
Join Date: Apr 2012
Posts: 1
lilmac556 is starting off with a positive reputation.
03 Expedition Water around the spark plugs!

I have an 03 expedition and I keep getting water in the cylinder 6, 7, and 8. It is blowing my coil packs and destroying my plugs. Where is it coming from and how do I stop it? The dealer told me to stop parking nose down on hills! WTH!!! Really? So much for built ford tough. What do people do in San fransico? Sorry honey we have to move, house is on the wrong side of the street for the truck. Seriously I need my truck to stop going into the shop monthly, can anyone help?
Reply With Quote
  #2  
Old 10-22-2013, 07:05 PM
inkink101 inkink101 is offline
New User
 
Join Date: May 2013
Posts: 9
inkink101 is starting off with a positive reputation.
If water is getting on your plugs use dielectric grease around spark plug boots, that should solve your problems!
Reply With Quote
  #3  
Old 10-25-2013, 07:59 AM
zhigaag's Avatar
zhigaag zhigaag is offline
Senior User
 
Join Date: Jun 2004
Posts: 106
zhigaag is starting off with a positive reputation.
Not sure if this applies directly but its the same problem.....
https://www.ford-trucks.com/forums/1...l#post12209418
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Testing oil cooler? deputydog03 1999 to 2016 Super Duty 6 09-28-2016 01:36 PM
03 Exped service engine soon light after spark plug change i.gon 1997-2006 Expedition & Navigator 6 01-08-2016 08:44 AM
What year 5.4 will swap into 03 F250? 03F250SD 1999 to 2016 Super Duty 3 09-11-2015 02:12 AM
Hissing when brake is released 03expymg 1997-2006 Expedition & Navigator 3 10-02-2012 12:13 PM
backup sensors not working 03 expedition JoeG112 1997-2006 Expedition & Navigator 2 11-13-2011 09:27 AM


Go Back   Ford Truck Enthusiasts Forums >

Tags
02, 03, 2000, 99, coil, cylinder, econoline, expedition, explorer, ford, plug, plugs, spark, v8, water

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 07:42 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: