Notices
1961 - 1966 F-100 & Larger F-Series Trucks Discuss the Slick Sixties Ford Truck

New Fuel Sending unit only going to 1/2 tank

 
  #16  
Old 01-21-2016, 08:09 PM
BrushPopper's Avatar
BrushPopper
BrushPopper is offline
Freshman User
Join Date: Nov 2011
Location: High country of Arizona
Posts: 32
BrushPopper is starting off with a positive reputation.
Sorry bout that... but since this a work in progress, when i first got the beast, I was informed it needed a new head gasket and it was running hot, so installed both new head gaskets, it was still showing hot, fuel guage was not even working then because of the bad sending unit, so I installed the aftermarket guage set for the temp. Then tackled the fuel guage.. got a new sending unit and finally discovered it also needed a new IVR... getting there, slowly but surely... now thinking of going back to the old temp guage, just trying to keep everything close to stock anyway.
 
  #17  
Old 01-21-2016, 10:37 PM
Tedster9's Avatar
Tedster9
Tedster9 is offline
Post Fiend
Join Date: Apr 2002
Location: Waterloo, Iowa
Posts: 14,960
Tedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputationTedster9 has a superb reputation
A lot of ICVRs get replaced unnecessarily. Ask me how I know. Little *******s cost 25 bucks new, too lol.
 
  #18  
Old 01-22-2016, 02:10 PM
BrushPopper's Avatar
BrushPopper
BrushPopper is offline
Freshman User
Join Date: Nov 2011
Location: High country of Arizona
Posts: 32
BrushPopper is starting off with a positive reputation.
OK well durn it all... fuel guage now works, oil guage is working fine... thinking of hooking the original temp sending unit back up... but in the meantime... I noticed the odometer is not working correctly... went out for about a 30 mile drive today and wrote mileage down so i could start calculating my gas mileage and it showed i went maybe 1.75 miles????..

the speedometer is working, so I am just wondering if i need to lubricate it or something?
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fivestarmmd
Large Truck
2
12-12-2017 09:21 PM
kevinmcc2
1948 - 1956 F1, F100 & Larger F-Series Trucks
1
06-16-2017 10:29 AM
GoatMoto
1973 - 1979 F-100 & Larger F-Series Trucks
5
03-10-2017 11:29 AM
RileyCarroll
1973 - 1979 F-100 & Larger F-Series Trucks
28
08-14-2016 01:51 PM
fordtruckguy98
1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks
8
07-12-2016 06:30 PM


Thread Tools
Search this Thread
Quick Reply: New Fuel Sending unit only going to 1/2 tank


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.