So what did you do to your 6.0L today? - Page 1305 - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Diesel > 6.0L Power Stroke Diesel
Reload this Page >

So what did you do to your 6.0L today?

Notices
6.0L Power Stroke Diesel 2003 - 2007 F250, F350 pickup and F350+ Cab Chassis, 2003 - 2005 Excursion and 2003 - 2009 van

So what did you do to your 6.0L today?

Reply

 
 
 
  #19561  
Old 03-13-2018, 06:45 PM
Amicus
Amicus is offline
Senior User
Join Date: Dec 2003
Location: hondo
Posts: 392
Amicus is gaining momentum as a positive member of FTE.
Originally Posted by Excurvelle View Post
$450 is about right, maybe a little cheap. Has the STC been replaced?
not isince I've had it. About a year
 
Reply With Quote
  #19562  
Old 03-13-2018, 08:28 PM
ConstantProject
ConstantProject is offline
Freshman User
Join Date: Oct 2014
Posts: 35
ConstantProject is starting off with a positive reputation.
Shocks!

Replaced the shocks that came with the truck when I got it (pro comp) and the stock steering damper with Blisteins and it was an immediate change, I'll see how long they last. The steering damper was factory and had leaked most of it's fluid already... Now I just need to find time for my 94 IDI
 
Reply With Quote
  #19563  
Old 03-13-2018, 09:00 PM
Yahiko's Avatar
Yahiko
Yahiko is offline
FTE Chapter Leader
Join Date: Apr 2012
Location: Spanaway
Posts: 20,699
Yahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputation
The only thing I did today was go for a drive and pick up the mail at the Post Office.
On top of that I really hate having to do HTML by hand.

The one thing I do need to do is rotate the tires.
 
Reply With Quote
  #19564  
Old 03-13-2018, 10:47 PM
Sparky83's Avatar
Sparky83
Sparky83 is online now
Posting Legend
Join Date: Jan 2009
Location: VB, Va/Norlina NC
Posts: 75,993
Sparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputation
well yesterday i put $60 into it as she was thirsty... today i made her a little hungry lol
 
Reply With Quote
  #19565  
Old 03-14-2018, 12:15 AM
Brown Falcon's Avatar
Brown Falcon
Brown Falcon is offline
Post Fiend
Join Date: Jul 2008
Location: Tangent,OR
Posts: 9,558
Brown Falcon has much to be proud ofBrown Falcon has much to be proud ofBrown Falcon has much to be proud ofBrown Falcon has much to be proud ofBrown Falcon has much to be proud ofBrown Falcon has much to be proud ofBrown Falcon has much to be proud ofBrown Falcon has much to be proud ofBrown Falcon has much to be proud ofBrown Falcon has much to be proud of
I swapped in my rebuilt FICM with 80hp Atlas tune. That was a pain in the ***, and to top it off the hose nipple broke off of the radiator. I drilled and tapped it for a barbed brass fitting. So far seems to work fine.

Took it it for a short test drive and it seems to spool much faster. Voltage was 48v cranking and right after startup, and 49v when running down the road.
 
Reply With Quote
  #19566  
Old 03-14-2018, 12:51 AM
rcboats1's Avatar
rcboats1
rcboats1 is online now
Junior User
Join Date: Jun 2007
Location: Everett, WA.
Posts: 66
rcboats1 is gaining momentum as a positive member of FTE.
Got one.

What I did today was buy one. My first 6.0 after several 7.3s. It needs some body work, but runs great.
 
Reply With Quote
  #19567  
Old 03-14-2018, 01:47 AM
Yahiko's Avatar
Yahiko
Yahiko is offline
FTE Chapter Leader
Join Date: Apr 2012
Location: Spanaway
Posts: 20,699
Yahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputationYahiko has a superb reputation
Originally Posted by rcboats1 View Post
What I did today was buy one. My first 6.0 after several 7.3s. It needs some body work, but runs great.
If you need any help your just north of me.
Also if you have not and would like to come join us in the Washington State Chapter of FTE.
 
Reply With Quote
  #19568  
Old 03-14-2018, 05:25 AM
Turd-250's Avatar
Turd-250
Turd-250 is offline
Post Fiend
Join Date: Apr 2017
Location: Oklahoma
Posts: 5,123
Turd-250 has a brilliant futureTurd-250 has a brilliant futureTurd-250 has a brilliant futureTurd-250 has a brilliant futureTurd-250 has a brilliant futureTurd-250 has a brilliant futureTurd-250 has a brilliant futureTurd-250 has a brilliant futureTurd-250 has a brilliant futureTurd-250 has a brilliant futureTurd-250 has a brilliant future
Oh nastyyyyy!!!
 
Reply With Quote
  #19569  
Old 03-14-2018, 06:57 AM
TooManyToys.'s Avatar
TooManyToys.
TooManyToys. is online now
Post Fiend
Join Date: Dec 2014
Location: Jersey Shore
Posts: 6,277
TooManyToys. has much to be proud ofTooManyToys. has much to be proud ofTooManyToys. has much to be proud ofTooManyToys. has much to be proud ofTooManyToys. has much to be proud ofTooManyToys. has much to be proud ofTooManyToys. has much to be proud ofTooManyToys. has much to be proud of
Is a bio-hazard suit required?
 
Reply With Quote
  #19570  
Old 03-14-2018, 08:00 AM
Y2KW57's Avatar
Y2KW57
Y2KW57 is offline
Postmaster
Join Date: Dec 2011
Posts: 3,479
Y2KW57 has a superb reputationY2KW57 has a superb reputationY2KW57 has a superb reputationY2KW57 has a superb reputationY2KW57 has a superb reputationY2KW57 has a superb reputationY2KW57 has a superb reputationY2KW57 has a superb reputationY2KW57 has a superb reputationY2KW57 has a superb reputationY2KW57 has a superb reputation
Leaking cab vents.
 
Reply With Quote
  #19571  
Old 03-14-2018, 08:39 AM
Sparky83's Avatar
Sparky83
Sparky83 is online now
Posting Legend
Join Date: Jan 2009
Location: VB, Va/Norlina NC
Posts: 75,993
Sparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputation
Originally Posted by Turd-250 View Post
Oh nastyyyyy!!!
i see a bear and/or imperial walker there...
 
Reply With Quote
  #19572  
Old 03-14-2018, 08:41 AM
Sparky83's Avatar
Sparky83
Sparky83 is online now
Posting Legend
Join Date: Jan 2009
Location: VB, Va/Norlina NC
Posts: 75,993
Sparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputationSparky83 has a superb reputation
Originally Posted by Brown Falcon View Post
I swapped in my rebuilt FICM with 80hp Atlas tune. That was a pain in the ***, and to top it off the hose nipple broke off of the radiator. I drilled and tapped it for a barbed brass fitting. So far seems to work fine.

Took it it for a short test drive and it seems to spool much faster. Voltage was 48v cranking and right after startup, and 49v when running down the road.
thats how i ended up buying a new radiator when i was changing the t-stat on mine.
 
Reply With Quote
  #19573  
Old 03-14-2018, 11:04 AM
texastech_diesel's Avatar
texastech_diesel
texastech_diesel is offline
Disgruntled Texan
Join Date: Jun 2007
Location: Weatherford, TX
Posts: 8,791
texastech_diesel has a superb reputationtexastech_diesel has a superb reputationtexastech_diesel has a superb reputationtexastech_diesel has a superb reputationtexastech_diesel has a superb reputationtexastech_diesel has a superb reputationtexastech_diesel has a superb reputationtexastech_diesel has a superb reputationtexastech_diesel has a superb reputationtexastech_diesel has a superb reputationtexastech_diesel has a superb reputation
It's doing the "long cold start" thing again the last week or three But as of today this time IPR% has crept up to 24% when hot and idling, after staying at 23% for roughly five years and 75k miles. The issue is still impacted by parking position, it only does it when parked flat and not when it's parked nose up in the driveway. Will do it within 8 hours flat (one day parked at work), will be fine for days parked nose up.

Survey says...... dummy plugs is my best guess, an o-ring starting to degrade and leaking down when the oil is hot, nose up means less leaks out. "Long start" means 3-5 seconds instead of nearly instantaneous and its pretty smooth when it pops off, so this has got to be a really small leak. No hot re-start issues that I've noticed, I've been meaning to record re-starts after .5 hour, 1 hour, etc and position but haven't started yet. I wonder if it's worth pulling the rails and redoing the injector top o-rings at the same time, they've never been off so since this is really just an annoyance and not a problem I might just do the plugs and see if anything changes.

It does have brand new Delo 400LE 5W-40 with a quart of HSS in it, so I'm probably about to go on a crusade over nothing since the IPR tick could be a lot of things and only changed with the new oil. HSS is a 3rd-OCI refresher dose per the bottle, I thought the truck did fine when it was super cold but HSS is cheaper than injectors. It's also probably time to put it on IDS, but just haven't had the time over something so minor.
 
Reply With Quote
  #19574  
Old 03-15-2018, 08:24 PM
kujo3692's Avatar
kujo3692
kujo3692 is offline
Senior User
Join Date: Jul 2015
Location: Wild and Wonderful WV
Posts: 118
kujo3692 is starting off with a positive reputation.
Shocks

put bilsteins at all the corners today, replacing the originals with 239K on them...interested to see how it rides tomorrow
 
Reply With Quote
  #19575  
Old 03-15-2018, 09:43 PM
Lubbockguy1979's Avatar
Lubbockguy1979
Lubbockguy1979 is offline
Postmaster
Join Date: Jan 2009
Location: Lubbock
Posts: 2,517
Lubbockguy1979 has a very good reputation on FTE.Lubbockguy1979 has a very good reputation on FTE.Lubbockguy1979 has a very good reputation on FTE.Lubbockguy1979 has a very good reputation on FTE.
Got these and a seat cover for the driver side bottom. Bet ill see some mpg out of these mods
 
Attached Images  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: So what did you do to your 6.0L today?


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.