!993 Ranger turns over but doesn't run - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Small Chassis Trucks > Ranger & B-Series
Reload this Page >

!993 Ranger turns over but doesn't run

Notices
Ranger & B-Series All Ford Ranger and Mazda B-Series models

!993 Ranger turns over but doesn't run

 
  #1  
Old 07-13-2011, 05:15 PM
Trobaugh1998
Trobaugh1998 is offline
New User
Thread Starter
Join Date: Jul 2011
Posts: 2
Trobaugh1998 is starting off with a positive reputation.
!993 Ranger turns over but doesn't run

I was driving and lost power had the truck towed back to the house. Had My uncle come over with his machine to plug in my truck and tell me what codes pop up. Well only one code came up I think it was 157, anyways it said Mass Air Flow Sensor. Ok go get one, get new spark plugs,wires , air filter, and a new fuel filter. Install everything and nothing. So I checked got spark so its not the coils. Smell gas so don't think its that.Timing chain is fine, belt is still good. I don't know what else to try, unless I send it to the shop which I can't afford. Any one with some info for me please speak up . LOL
 
  #2  
Old 07-13-2011, 05:21 PM
Trobaugh1998
Trobaugh1998 is offline
New User
Thread Starter
Join Date: Jul 2011
Posts: 2
Trobaugh1998 is starting off with a positive reputation.
The engine is a 2.3 L and has about 150,00 miles on it.
 
  #3  
Old 07-13-2011, 05:26 PM
lincolncobra4.6
lincolncobra4.6 is offline
New User
Join Date: Jul 2011
Location: forest city nc.
Posts: 24
lincolncobra4.6 is starting off with a positive reputation.
1st. things to check r spark and fuel ! 2nd. if spins to easy over, timing belt ! thats it.
 

Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.