88 xlt 4x4, 2.3L...gas gauge not working. - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Small Chassis Trucks > Ranger & B-Series
Reload this Page >

88 xlt 4x4, 2.3L...gas gauge not working.

Notices
Ranger & B-Series All Ford Ranger and Mazda B-Series models

88 xlt 4x4, 2.3L...gas gauge not working.

 
  #1  
Old 04-01-2011, 08:52 PM
blucollar4xford's Avatar
blucollar4xford
blucollar4xford is offline
Elder User
Thread Starter
Join Date: Aug 2004
Location: New Lexington, Ohio
Posts: 726
blucollar4xford is starting off with a positive reputation.
88 xlt 4x4, 2.3L...gas gauge not working.

I just picked up an 88 xlt 4x4 for $300, great little truck so far. Needs a ps pump, rear hangers/shackles, and the fuel gauge doesn't work. I'm just wondering if there may be anything common on these trucks that might cause this. I'm working midnights so I can't just go look right now (basically got it home and now I'm leaving). I'll probably be checking it out tommorrow.
 
  #2  
Old 04-01-2011, 10:01 PM
Dutter's Avatar
Dutter
Dutter is offline
Elder User
Join Date: Jul 2010
Location: Paradise CA
Posts: 713
Dutter is starting off with a positive reputation.
Yeah the only thing i can think of would be the float or the gauge its self
 
  #3  
Old 04-02-2011, 08:39 AM
pawpaw
pawpaw is offline
Moderator
Join Date: Jan 2004
Location: SW Va
Posts: 12,461
pawpaw is a splendid one to beholdpawpaw is a splendid one to beholdpawpaw is a splendid one to beholdpawpaw is a splendid one to beholdpawpaw is a splendid one to beholdpawpaw is a splendid one to beholdpawpaw is a splendid one to behold
If the wiring & gauge check out, before pulling the bed for a fuel pump/sender change out, maybe consider trying a couple tanks of Techron Concentrate Plus treated gas, to see if it might be sender corrosion from fuel with more sulfer content than allowed, used in the past. Chevron claims Techron will clean up & prevent corrosion on fuel sending units.

A few years back, Shell & fuel Marketers that bought base fuel from Shell, let some gas hit the market with high levels of sulfur, that took out fuel pumps & sender units, so if the previous owner was known to use Shell gas in the mid 2000's, I'd maybe give the Techron treatment a try & see what happens. The least you'd get is a good clean fuel system, injectors, intake valves & combustion chambers & just maybe if your lucky, a working gas gauge, if sender corrosion is your problem.

More thoughts for consideration, let us know how it goes.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
joegeds
1987 - 1996 F150 & Larger F-Series Trucks
18
04-01-2013 02:32 PM
86f250XLT-4x4
Pre-Power Stroke Diesel (7.3L IDI & 6.9L)
4
11-17-2011 05:00 PM
prblack
1987 - 1996 F150 & Larger F-Series Trucks
9
07-27-2006 09:57 PM
jas88
1987 - 1996 F150 & Larger F-Series Trucks
2
06-16-2006 10:18 AM
leegarcia84
Aerostar
0
05-19-2004 02:55 PM


Thread Tools
Search this Thread
Quick Reply: 88 xlt 4x4, 2.3L...gas gauge not working.


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.