View Single Post
  #148  
Old 05-01-2010, 10:58 AM
tomatillo tomatillo is offline
New User
 
Join Date: Apr 2010
Posts: 3
tomatillo is starting off with a positive reputation.
Dealer installed OLD model IWE solenoid, CHARGED $350!

I'm hoppin mad at this point. First, thank you XJCamaro89 for posting this information.

I took articles from the forum in to the Ford dealer. The shop called and told me it was fixed. I checked under the hood and saw THEY REPLACED IT WITH THE SAME PART NUMBER. No new part with the shield to keep it from happening again. When questioned, the mechanic said the TSB didn't apply to my VIN -- 2005 F-150.

Called Ford Cust. Service. Gave them the TSB. Got them to say it applied to me, my VIN. They call the shop on my behalf. Shop tells them the solenoid without the shield, etc., was new and improved beyond what the TSB said. I asked Ford was there another TSB that superceded that one, with regard to this. "Sir, your TSB is from 2006. Ford is always improving its parts and the shop manager said the solenoid they installed is what is recommended for your truck."

It's complete BS.

Worse, the guy said the old solenoid checked out fine but he replaced it anyway based on the copied stuff I brought them from the forum.

I'll bet the grinding and clunk and no 4WD light is actuator-related.

What can I do when Ford won't back me up on that TSB?

Advice, please. I want to hurt somebody over that $350 for the inferior part. I can see I'm not alone on being ripped of over this issue, however. At least that's some consolation.
Reply With Quote