View Single Post
  #1  
Old 06-30-2014, 05:39 PM
jjsfamily jjsfamily is offline
New User
 
Join Date: Jun 2014
Posts: 3
jjsfamily is starting off with a positive reputation.
NEW to the forums - Need help with 1999 ford f150 4.6 triton v8

Any help is greatly appreciated first off. I am trying to diagnose an bad dpfe on a 1999 ford f150 with 4.6 and auto trans. I have used the below referenced website to do diagnostics on various parts on the truck.

Part 1 -How to Test the Ford EGR Valve and DPFE Sensor.

I have been trying to clear up any and all problems and misses on this truck for a while now. The truck sounds like it idles without missing but when you hit the throttle, the engine stumbles and doesn't have any power and occasionally snap or pop like a backfire. When you put the pedal to the floor, it wants to kill but eventually does pick up the rpms then sounds fairly normal. Trying to drive it down the road, once you get above about 3000 rms the truck seems to run "better" however wont get past 60 mph.

all checks from the above mentioned website say the iac, egr, tps, coil packs, etc are all good. except for the dpfe. I get almost 5 volts on wire top wire in connector. The middle wire I get 12 volts and 5 volts on the bottom wire. Is that saying that the dpfe is bad? also, when vacuum is applied on the egr nipple, the voltage does not go up or down on top wire of dpfe.

I am very stumped at this point.

Any and all help is greatly appreciated and very sorry in advance about the long winded post.
Reply With Quote