View Single Post
  #1  
Old 04-07-2014, 11:38 PM
Wayne Waldrep's Avatar
Wayne Waldrep Wayne Waldrep is offline
Elder User
 
Join Date: Aug 2012
Location: Cuba, AL (NO internet)
Posts: 712
Wayne Waldrep has a very good reputation on FTE.Wayne Waldrep has a very good reputation on FTE.Wayne Waldrep has a very good reputation on FTE.Wayne Waldrep has a very good reputation on FTE.
Radiator woes continue

Went to the trouble of pulling my radiator out because I thought I had a leak. All we found at the radiator shop was a slight leak in the petcock. Put a new one in and reinstalled the radiator. I filled the radiator and started the truck to burp the air out.....cap not on yet obviously. I watched like a hawk on the radiator and under the truck. Not a drip or drop at all. After about ten mins of running and letting the coolant circulate, I put the cap on. Instantly coolant started coming out of the overflow tube. This is a new 4# cap. The coolant wasn't even hot. I took the cap off...truck still running and coolant not even hot enough to blow out when removing the cap...and the overflow stopped completely. Cap back on, coolant flowing out overflow tube, cap off, stops again. I haven't even finished adding the coolant that came out of it back in yet. Never experienced this and I'm getting tired of this radiator. Any ideas because I have none on this. Thanks!
__________________

'49 F1 239 Flathead
Click to see my Gallery http://tinyurl.com/p4xegzv
www.waynewaldrep.com/God
Reply With Quote