View Single Post
  #4  
Old 09-07-2013, 02:43 PM
sammie0126's Avatar
sammie0126 sammie0126 is offline
Postmaster
 
Join Date: Aug 2012
Location: Westfield, Indiana
Posts: 2,678
sammie0126 has a superb reputationsammie0126 has a superb reputationsammie0126 has a superb reputationsammie0126 has a superb reputationsammie0126 has a superb reputationsammie0126 has a superb reputationsammie0126 has a superb reputationsammie0126 has a superb reputationsammie0126 has a superb reputationsammie0126 has a superb reputationsammie0126 has a superb reputation
Quote:
Originally Posted by rockcrawler_101 View Post
That doesn't seem to far off of where it should be. Are you getting play in your steering while drivin? Have someone turn the wheel while you look for play in the rest of the steering and pan hard bar.
I am - lot of play and I can't find it, yanked pulled and pried on everything I can and nothing. Brother going to be here in a few and am going to video the entire steering while he turns the wheel. Something is not right, thought it was the pump which was squealing; but replaced that and it's still driving like a drunken sailor. Everything in the steering is new in the last year, this started when the pump started going, or most likely it was there and just showed itself when the pump let go. Will follow up when I get a look at it all in motion again. FRUSTRATING!
__________________
~Christina

2000 Ford Excursion 4x4 6.8L V10 85k
"The secret to a happy life is a bad memory"
Reply With Quote