View Single Post
  #1  
Old 06-14-2012, 01:14 AM
Nsaan's Avatar
Nsaan Nsaan is offline
Posting Guru
 
Join Date: Aug 2010
Posts: 1,001
Nsaan has a great reputation on FTE.Nsaan has a great reputation on FTE.Nsaan has a great reputation on FTE.Nsaan has a great reputation on FTE.Nsaan has a great reputation on FTE.
looking for an Excursion....

I found one on Craigslist the other day, it is a 2000 Limited 4x4 with the 7.3, it has 176K miles on it now.

I called the owners and it turns out they use the same mechanic I do and looked up the service history on it, the first was in 06' when it had 65K miles on it, shortly after they bought it. I saw that it has had regular oil changes, a power steering pump, the rear end was rebuilt 2 years ago. It has had a billet grill and new lights and front bumper put on it. New rear bumper after someone rear ended it. It has a small dent on the hood where it looks like someone slammed the hood with something under it.
It has new batteries and alternator within the past year. It has a 4 inch lift on it. It also has a Edge Evolution programmer on it right now. AFE intake and 4 inch magnaflow exhaust.

When i was looking at the service history on it I did not find ANY transmission services or rebuilds on it.
I talked to the owner and he NEVER had any done. 108k miles and NO trans service. I pulled the dipstick and checked it. It was reddish brown but did not smell burnt. That made me feel a little better.
I fired it up, the engine was cold... (as it could be being 100+ outside.) It started easy and i ran around to check the exhaust. It sounded good and strong. No exhaust leaks to be found. No smoke at all at idle. I pulled off the oil cap and checked for blow by, it sat there solid with no movement. No puff at all.

Now the fun, the test drive. I checked the A/C works , all the windows work. I drove it down the street and around the corner, got out of the neighborhood and layed into it hard. IT HAULED A$$! I turned onto the main road and floored it, It LIT the tires off the line. (guess that is why it needs tires, it has 325/65r18 Nitto all terrains) I stayed in it it hit second and chirped the tires, I let out a bit and it shifted to 3rd and then 4th at just under 90. Shifts were firm and did not slip at all. I drove it back and asked the guy what level the chip was on. He said it was on the highest. (100hp)
It shifted just fine when you were driving it normal. I guess that is good for a trans that has been neglected for that long. I am wondering if the chip is what has kept the trans alive for so long. They have towed with it occasionally like a 25 foot enclosed toyhauler with 2 rhinos in it.

The bad, it needs new tires, Discount wants 1200-1500 for a set...
it needs the drivers seat and arm rest recovered.... it could stand to be detailed, but for a 12 year old family vehicle it is OK.

Now for the question... Would you buy a vehicle that has had the trans not serviced for 6 years and over 108K miles?

I am torn on this one. Your thoughts???

It would be the Family vehicle... the price is good but not good enough that I don't mind taking a chance on the trans going to crap after putting 1200 in tires on it....
__________________
Donn
1999 F450 7.3, 4r100, 4.88 gears, Scelzi utility bed, 14K lbs
1998 Dodge 2500 SLT, Quad cab, 4x4, Cummins, 5spd 35's 4" exhaust
Hers 2000 Excursion 7.3 4x4 4inch lift 33's RR inserts, boots, bellowed uppipes 4" turbo back exhaust
A.E. Domestic Bundle. (Ford, Dodge, Chevy)
Reply With Quote