Ford Truck Enthusiasts Forums - Search Results
 

Go Back   Ford Truck Enthusiasts Forums > Search Forums
Log In 


Showing results 1 to 15 of 65
Search took 0.17 seconds.
Search: Posts Made By: johngeorge
Forum: 2015+ F150 07-27-2016, 01:55 AM
Replies: 11
Views: 266
Posted By johngeorge
I just watched a few youtube videos of 5.0 trucks...

I just watched a few youtube videos of 5.0 trucks with a Aero Turbine AT3030 swapped in place of the factory muffler. Still had the factory piping and resonator. Sounded pretty good.
Forum: 2015+ F150 07-26-2016, 06:12 PM
Replies: 11
Views: 266
Posted By johngeorge
Muffler Replacement

I have a 2015 F150 with a 5.0. The prices of the cat back kits are ridiculous. I'm just wondering if anyone has replaced the muffler only. If so, how was the sound? I'm just wanting a better sound.
Forum: 1987 - 1996 F150 & Larger F-Series Trucks 11-02-2015, 06:39 PM
Replies: 5
Views: 283
Posted By johngeorge
Yes to the tune up. I should have mentioned that...

Yes to the tune up. I should have mentioned that it is also losing about a quart of coolant every few hundred miles. None in the oil so I guess it's going out the exhaust.
Forum: 1987 - 1996 F150 & Larger F-Series Trucks 11-02-2015, 03:53 PM
Replies: 5
Views: 283
Posted By johngeorge
Finding a Crate Motor

I have a 95 EB 4X4 Supercab with the 5.8. 306,000 miles and it's never been torn into. It's getting tired when I tow the camper with it. Only about 5,000 lbs. Looking for recommendations on where to...
Forum: 1987 - 1996 F150 & Larger F-Series Trucks 11-02-2015, 03:37 PM
Replies: 11
Views: 601
Posted By johngeorge
If you pull it apart again check the crank. I...

If you pull it apart again check the crank. I have seen it scratched from people using a sheet metal screw and pliers to remove the old seal. If it is scratched it is an easy fix. Clean it, sand it...
Forum: Appearance & Dress-Up 03-19-2014, 09:27 PM
Replies: 0
Views: 350
Posted By johngeorge
Cleaning the roof of Expedition

Just got one that was sitting under pine trees for several months. I typically use a telescoping brush for this type job but it's not cleaning this one. Anyone have any tips on what cleaners I can...
Forum: 2004 - 2008 F150 03-07-2014, 07:44 PM
Replies: 1
Views: 496
Posted By johngeorge
5.4L 3V #3 cylinder no signal

I know the COP and injector have a constant positive and get a negative signal from the PCM. I replaced the PCM and still no signal to the injector or COP on #3. I ohmed each circuit to ensure their...
Forum: Expedition & Navigator 10-27-2013, 02:22 PM
Replies: 14
Views: 3,153
Posted By johngeorge
Update: I cut the signal (negative) wire to the...

Update: I cut the signal (negative) wire to the coil. I cut it about an inch or so from the PCM connector and the same at the COP connector. I scabbed in another wire. Now when I use my homemade...
Forum: Expedition & Navigator 10-20-2013, 12:33 PM
Replies: 14
Views: 3,153
Posted By johngeorge
After many hours of ohming wires and checking...

After many hours of ohming wires and checking circuits I have concluded I need a PCM. My question is: Which of the numbers on the PCM's need to match? Mine are as follows:

Motorola SN:...
Forum: Expedition & Navigator 10-20-2013, 12:31 PM
Replies: 5
Views: 973
Posted By johngeorge
PCM swap help needed

After many hours of ohming wires and checking circuits I have concluded I need a PCM. My question is: Which of the numbers on the PCM's need to match? Mine are as follows:

Motorola SN:...
Forum: Expedition & Navigator 10-14-2013, 08:18 PM
Replies: 0
Views: 531
Posted By johngeorge
DO I need a PCM or EMC

http://www.ford-trucks.com/forums/1272383-06-5-4-cylinder-3-misfire-p0353.html This is a link to the thread I started about my problem. It has info about the diagnostics I performed. I believe I...
Forum: Expedition & Navigator 10-14-2013, 03:49 PM
Replies: 14
Views: 3,153
Posted By johngeorge
OK, I hope I explain this well. Voltages checked...

OK, I hope I explain this well. Voltages checked good. I ohmed the negative or signal side of the circuit and Key off got 95 ohms. Any of the other seven got OL or no continuity. KOEO and it went up...
Forum: Expedition & Navigator 10-10-2013, 09:55 PM
Replies: 14
Views: 3,153
Posted By johngeorge
Thanks for the help. I am leaving for a long...

Thanks for the help. I am leaving for a long weekend in the morning so it will be Monday before I will be able to get back on this. I will post my findings. Thanks again for the info.
Forum: 2004 - 2008 F150 10-10-2013, 08:30 PM
Replies: 5
Views: 988
Posted By johngeorge
I did. I sent you a link. Sorry if I overstepped.

I did. I sent you a link. Sorry if I overstepped.
Forum: Expedition & Navigator 10-10-2013, 04:20 PM
Replies: 14
Views: 3,153
Posted By johngeorge
I used a test light on the #3 connector. KOEO and...

I used a test light on the #3 connector. KOEO and the light was on constant. I stuck a paper clip in the signal side, started the engine, connected the clip of the test light to the paper clip and...
Showing results 1 to 15 of 65

 
Forum Jump
 


All times are GMT -5. The time now is 03:28 PM.

 

Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup