Ford Truck Enthusiasts Forums - Search Results
 

Go Back   Ford Truck Enthusiasts Forums > Search Forums
Log In 


Showing results 1 to 15 of 500
Search took 0.22 seconds.
Search: Posts Made By: IDIDieselJohn
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 01-04-2016, 07:20 PM
Replies: 18
Views: 377
Posted By IDIDieselJohn
Ahhh I see, didn't know that, thanks! I'll give...

Ahhh I see, didn't know that, thanks! I'll give it a try once the temp warms up abit, -10*F here right now for 3 days.
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 01-04-2016, 06:29 PM
Replies: 18
Views: 377
Posted By IDIDieselJohn
I removed the clip to remove the old broken...

I removed the clip to remove the old broken cable, stuck the new cable in the hole, and put the clip back on?

You have to remove the whole thing to do it properly is what you're saying?


Tach...
Forum: 1987 - 1996 F150 & Larger F-Series Trucks 01-03-2016, 03:54 PM
Replies: 3
Views: 175
Posted By IDIDieselJohn
I'll give it a try, I do remember checking it,...

I'll give it a try, I do remember checking it, and it looked pretty clean actually.
Forum: 1987 - 1996 F150 & Larger F-Series Trucks 01-03-2016, 03:08 PM
Replies: 3
Views: 175
Posted By IDIDieselJohn
'94 F150 5spd, no Reverse lights

Good afternoon everyone!

So on my '94 F150 shorty 4x4 5spd, 300-6 it's got no back up lights, hasn't for a few years now, and i'm just about done with backing up in the woods at night not seeing...
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 01-03-2016, 02:53 PM
Replies: 18
Views: 377
Posted By IDIDieselJohn
Update: So got a new cable in, (6$ at...

Update:

So got a new cable in, (6$ at Autozone), had to take the cluster back off 4 times after installing the new cable, speedo still wasn't working, first time, it just popped out from behind...
Forum: 1968-2013 Full Size Vans 12-27-2015, 08:55 PM
Replies: 9
Views: 367
Posted By IDIDieselJohn
This could be the voltage regulator that always...

This could be the voltage regulator that always goes bad in these van clusters, have you noticed the gas and oil pressure gauge go up to?


In my '91 Diesel club wagon, this is really bad if I use...
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 12-22-2015, 08:45 PM
Replies: 18
Views: 377
Posted By IDIDieselJohn
Well the cable is still properly hooked up behind...

Well the cable is still properly hooked up behind the cluster, great. Hopefully I finish early enough tomorrow to go look under.
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 12-21-2015, 06:39 PM
Replies: 18
Views: 377
Posted By IDIDieselJohn
Ahhh thanks for that, it could have a stand alone...

Ahhh thanks for that, it could have a stand alone computer, as this truck was originally a 5spd, the E4OD was swapped in many years ago, and the wires off the tach sensor, run down the engine, their...
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 12-20-2015, 06:57 PM
Replies: 18
Views: 377
Posted By IDIDieselJohn
The non working speedo doesn't bother me, be the...

The non working speedo doesn't bother me, be the 3rd vehicle I have that doesn't have a working speedo haha.

The tranny bothers me though, it was working perfect till that. I know on the 92+...
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 12-20-2015, 06:52 PM
Replies: 10
Views: 271
Posted By IDIDieselJohn
Sounds like your kick down rod got stuck on...

Sounds like your kick down rod got stuck on something, holding it down, making the transmission think your flooring it all the time.


Get it unstuck if that's the issue, and lube up the linkage...
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 12-20-2015, 06:49 PM
Replies: 18
Views: 377
Posted By IDIDieselJohn
E4OD issues, lost cable driven Speedo...?

Evening guys, been a while!

So on my '91 F350 4x4, E4OD just got it running again after fuel issues, (pump, lines, everything that can make it hard on the starter) anyways thankfully that's over...
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 08-31-2015, 11:48 AM
Replies: 3
Views: 197
Posted By IDIDieselJohn
Sorry for taking so long to reply, I seem to have...

Sorry for taking so long to reply, I seem to have fixed the problem.

I took off the controller from the engine, everything looked fine, connections and all, but I did a rusty nut under the relay,...
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 08-31-2015, 11:45 AM
Replies: 5
Views: 266
Posted By IDIDieselJohn
Another one! with a question

Hi everyone, been a while.

So I just acquired a 1991 F350 4x4 dually 5spd 7.3, cab/chassis truck.

Great shape, 204,000km (127k miles), clean inside and out, everything works. However, i've...
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 07-26-2015, 12:23 PM
Replies: 3
Views: 197
Posted By IDIDieselJohn
WTS light question

Hi everyone, been a while!

Got a quick question here,

In my '91 E250 Club Wagon, every now and then, the glow plugs don't work, acts like it's got a couple burnt out plugs. Dead cold engine,...
Forum: Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 07-12-2015, 11:43 PM
Replies: 55
Views: 2,080
Posted By IDIDieselJohn
Wanna go faster? Buy a new truck, end of story! ...

Wanna go faster? Buy a new truck, end of story!


If you have any money left after buying the newer truck, kiss it goodbye on maintenance!!!
Showing results 1 to 15 of 500

 
Forum Jump
 


All times are GMT -5. The time now is 01:51 AM.

 

Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup