Go Back   Ford Truck Enthusiasts Forums > Search Forums
Sign in using an external account
Register Forgot Password?


Showing results 1 to 15 of 499
Search took 0.29 seconds.
Search: Posts Made By: Paul T
Forum: Excursion - King of SUVs 04-08-2015, 11:33 AM
Replies: 35,241
Views: 1,429,530
Posted By Paul T
On my 2003 Ex I cleaned & greased brake slide...

On my 2003 Ex I cleaned & greased brake slide pins on drivers side, one was stuck, replaced slide pins on passenger side. One was really stuck so I had to heat it up to get it out and that melted the...
Forum: 1987 - 1996 F150 & Larger F-Series Trucks 01-16-2015, 05:26 PM
Replies: 2
Views: 216
Posted By Paul T
Sorry, I meant Heavy-Duty.

Sorry, I meant Heavy-Duty.
Forum: 1987 - 1996 F150 & Larger F-Series Trucks 12-31-2014, 04:09 PM
Replies: 2
Views: 216
Posted By Paul T
Rear tank not working.

I have a 96 F250 Super-duty 4x4 SB Crew, it had been sitting for over a year while I made time to fix the rusted out left rear spring shackle. After the repair I started driving it and noticed that...
Forum: 1987 - 1996 F150 & Larger F-Series Trucks 12-31-2014, 03:22 PM
Replies: 18,227
Views: 1,177,559
Posted By Paul T
Finally got my left rear shackle bracket put on...

Finally got my left rear shackle bracket put on my 96 F250 SB Super Crew 4x4. It was a PIA but I got it on. I also bought the right shackle bracket to put on when it rusts off. Working on why the...
Forum: Modular V10 (6.8l) 08-25-2014, 08:37 PM
Replies: 15
Views: 1,879
Posted By Paul T
Update: I changed the #6 coil and all seems to be...

Update: I changed the #6 coil and all seems to be fixed. I took it on a 6 mile trip and all seems well. No stalling, missing, or dieing and no codes. I will post again if it is not fixed. Thanks for...
Forum: Excursion - King of SUVs 08-25-2014, 08:33 PM
Replies: 38
Views: 2,266
Posted By Paul T
Update: I changed the #6 coil and all seems to be...

Update: I changed the #6 coil and all seems to be fixed. I took it on a 6 mile trip and all seems well. No stalling, missing, or dieing and no codes. I will post again if it is not fixed. Thanks for...
Forum: Modular V10 (6.8l) 08-10-2014, 12:23 PM
Replies: 15
Views: 1,879
Posted By Paul T
Thanks, Mark for the advice. I checked the fuel...

Thanks, Mark for the advice. I checked the fuel pressure today and with the key on no start it pressurized up to 36psi. After I started it, it went to 32psi and held. I am leaning toward a bad COP. I...
Forum: Excursion - King of SUVs 08-10-2014, 12:20 PM
Replies: 38
Views: 2,266
Posted By Paul T
I checked the fuel pressure today and with the...

I checked the fuel pressure today and with the key on no start it pressurized up to 36psi. After I started it it went to 32psi and held. I am leaning toward a bad COP. I am still only getting the...
Forum: Modular V10 (6.8l) 08-09-2014, 09:27 AM
Replies: 15
Views: 1,879
Posted By Paul T
What should the reading be at the plug? Would a...

What should the reading be at the plug? Would a bad ground cause this? I admit I have very limited knowledge with a meter. I checked with the local Ford dealer and they wanted $85 to put it on their...
Forum: Modular V10 (6.8l) 08-08-2014, 08:43 PM
Replies: 15
Views: 1,879
Posted By Paul T
Update: I changed the plugs, boots, & springs...

Update: I changed the plugs, boots, & springs tonight and took it for a 3 mile drive to my Mother-in-laws. X was running great until I got there and put it in reverse and it died. Restarted and put...
Forum: Excursion - King of SUVs 08-07-2014, 09:28 PM
Replies: 38
Views: 2,266
Posted By Paul T
Update: I changed the plugs, boots, & springs...

Update: I changed the plugs, boots, & springs tonight and took it for a 3 mile drive to my Mother-in-laws. X was running great until I got there and put it in reverse and it died. Restarted and put...
Forum: Excursion - King of SUVs 07-27-2014, 06:52 PM
Replies: 38
Views: 2,266
Posted By Paul T
UPDATE: I thought I would check the plug boots...

UPDATE: I thought I would check the plug boots and springs today on the drivers side. I could not find anything out of the ordinary except I noticed a lot of dust and like fine sand in the plug...
Forum: Ranger & B-Series 07-27-2014, 04:15 PM
Replies: 6
Views: 448
Posted By Paul T
Update - I finally found the problem with the...

Update - I finally found the problem with the truck. After new altenator, plugs, wires, TPS, battery, & coil pack. I broke down and took it to a shop. They found antifreeze in cylinder 6. It has a...
Forum: Modular V10 (6.8l) 07-22-2014, 04:58 PM
Replies: 15
Views: 1,879
Posted By Paul T
Thanks Jason, I think I will do a plug boot &...

Thanks Jason, I think I will do a plug boot & spring change. I will let you know what happens.
Forum: Excursion - King of SUVs 07-22-2014, 04:43 PM
Replies: 38
Views: 2,266
Posted By Paul T
Thanks guys, I will check those things out.

Thanks guys, I will check those things out.
Showing results 1 to 15 of 499

 
Forum Jump
 

Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »


All times are GMT -5. The time now is 05:22 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup