Go Back   Ford Truck Enthusiasts Forums > Search Forums
Sign in using an external account
Register Forgot Password?


Showing results 1 to 8 of 8
Search took 0.02 seconds.
Search: Posts Made By: zweave
Forum: Modular V8 (4.6L, 5.4L) 06-19-2014, 10:09 PM
Replies: 1
Views: 240
Posted By zweave
Tried to start it with out the cable and the...

Tried to start it with out the cable and the battery light and passenger airbag light on the dash don't shut off. I get the low voltage solenoid click. Might be a dead battery but I highly doubt it...
Forum: Modular V8 (4.6L, 5.4L) 06-19-2014, 11:02 AM
Replies: 1
Views: 240
Posted By zweave
wiring issue 99 4.6

I recently did an engine swap to a 96 cougar xr-7 after I blew my origional engine. I have the intake manifold and throttle body and wiring harness off of the f150 since the connections didn't work...
Forum: 2004 - 2008 F150 05-28-2014, 11:49 AM
Replies: 2
Views: 373
Posted By zweave
if you idle normal with your a/c off and not...

if you idle normal with your a/c off and not turning the wheel so no additional accessories are putting stress on the engine then it could be your IAC valve (idle air control)
Forum: Modular V8 (4.6L, 5.4L) 04-22-2014, 09:41 PM
Replies: 6
Views: 1,272
Posted By zweave
crank position sensor code is also thrown

crank position sensor code is also thrown
Forum: Modular V8 (4.6L, 5.4L) 04-22-2014, 09:39 PM
Replies: 6
Views: 1,272
Posted By zweave
alright so i just got my vehicle home and i...

alright so i just got my vehicle home and i checked my dipstick and its way way way past full so that 2 quarts i added when the light came on wasnt good. when i was at my friends shop we put an...
Forum: Modular V8 (4.6L, 5.4L) 04-21-2014, 11:01 PM
Replies: 6
Views: 1,272
Posted By zweave
i believe the wire went to O2 sensors. when i got...

i believe the wire went to O2 sensors. when i got my exhaust put on i took the O2s out and removed my cats
Forum: Modular V8 (4.6L, 5.4L) 04-21-2014, 11:00 PM
Replies: 6
Views: 1,272
Posted By zweave
i only replaced the tensioners because one was...

i only replaced the tensioners because one was broke. but today i was driving and my oil pressure guage went down to low and the light came on when i was at a stop light so i thought the guage was...
Forum: Modular V8 (4.6L, 5.4L) 04-17-2014, 10:28 PM
Replies: 6
Views: 1,272
Posted By zweave
engine rattle 99 4.6

i just redid the timing tensioners hoping it would resolve the knocking/rattling. one was broken and the chain doesnt sound like it drags and flops around anymore but there is still a sort of...
Showing results 1 to 8 of 8

 
Forum Jump
 

Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 03:26 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup