Go Back   Ford Truck Enthusiasts Forums > Search Forums
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


Showing results 1 to 15 of 29
Search took 0.28 seconds.
Search: Posts Made By: SBrown732
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 04-29-2009, 02:18 PM
Replies: 40
Views: 1,144
Posted By SBrown732
You may want to check that your choke is open at...

You may want to check that your choke is open at operating temperature. I had a problem with my engine stalling under load and found that to be my problem. I used the choke cap to adjust.
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 04-28-2009, 08:31 AM
Replies: 12
Views: 353
Posted By SBrown732
Looking good. Keep us posted.

Looking good. Keep us posted.
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 04-23-2009, 08:10 AM
Replies: 35
Views: 970
Posted By SBrown732
Starting to tackle the engine compartment. ...

Starting to tackle the engine compartment. Re-routing plug wires, painting under the hood and general dress up.
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 04-20-2009, 01:48 PM
Replies: 55
Views: 18,280
Posted By SBrown732
Great post! I just corrected a rich condition on...

Great post! I just corrected a rich condition on my Edelbrock by properly adjusting the choke cap at operating temperature. Big performance improvement...
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 04-13-2009, 04:46 PM
Replies: 7
Views: 718
Posted By SBrown732
Went to Edelbrock's site and downloaded the...

Went to Edelbrock's site and downloaded the manual. When I pulled the truck into the garage, I let it warm up to operating temperature with the air cleaner off. I noticed that the choke was barely...
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 04-13-2009, 04:35 PM
Replies: 38
Views: 1,389
Posted By SBrown732
Beautiful truck! Great job, I hope you enjoy it.

Beautiful truck! Great job, I hope you enjoy it.
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 04-08-2009, 08:28 PM
Replies: 14
Views: 315
Posted By SBrown732
It's looking great. You should be proud. Nice...

It's looking great. You should be proud. Nice work.
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 04-07-2009, 08:11 AM
Replies: 7
Views: 718
Posted By SBrown732
Thanks for the responses. For the float, what...

Thanks for the responses. For the float, what could be the problem and how would I address? Could it be sticking (the truck sat for a long time before I bought it and it sits in storage for 5...
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 04-05-2009, 07:56 PM
Replies: 7
Views: 718
Posted By SBrown732
Missing & Stall Problem: 1977 F-100, 302 Engine

I have a 1977 F-100 with a 302 engine and an Edelbrock 500 CFM carburetor. I have an intermittent issue with the engine missing and at times stalling. This usually occurs under a load like climbing...
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 11-29-2007, 08:50 PM
Replies: 8
Views: 293
Posted By SBrown732
Cleaned the corrosion and replaced the bulbs. ...

Cleaned the corrosion and replaced the bulbs. Lights up like new again!

However, the left turn signal indicator still comes on when I turn on the dash lights. Again, no burn marks or defects...
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 10-29-2007, 06:48 PM
Replies: 8
Views: 293
Posted By SBrown732
Thank for the help! What would be the best way...

Thank for the help! What would be the best way to clean the corrosion? Also, any wiring schematic info so I can check the ground wire from the connector?

Thanks,
Steve
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 10-29-2007, 03:06 PM
Replies: 8
Views: 293
Posted By SBrown732
Printed Circuit Failure? 1977 F-100

I am having a problem with the dash cluster lighting on my 1977 F-100. When I turn on the lights, the only bulb that illuminates is the left turn signal bulb. It blinks properly but stays...
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 10-22-2007, 07:29 PM
Replies: 5
Views: 288
Posted By SBrown732
Sorry to say that the factory plug was cut off by...

Sorry to say that the factory plug was cut off by whoever installed the aftermarket radio that was in the truck when I bought it. I didn't notice any loose wires that had current when the key switch...
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 10-22-2007, 03:28 PM
Replies: 5
Views: 288
Posted By SBrown732
Radio Interference - 1977 F-100

I let this question sit for a couple of weeks on the audio forum with no response. Thought I would see if I could get any help here...

During my restoration, I installed a 1970's era factory...
Forum: 1973 - 1979 F-100 & Larger F-Series Trucks 10-19-2007, 03:19 PM
Replies: 2
Views: 232
Posted By SBrown732
Question Headlight Adjustment

The headlights on my 1977 F-100 are out of adjustment (one shines on the road and the other points high). Is there any gauge, tool or procedure to adjust the headlights properly? I know that there...
Showing results 1 to 15 of 29

 
Forum Jump
 


All times are GMT -5. The time now is 07:36 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup