Go Back   Ford Truck Enthusiasts Forums > Search Forums
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


Showing results 1 to 12 of 12
Search took 0.16 seconds.
Search: Posts Made By: thmitch79
Forum: Crossovers 10-16-2014, 05:42 PM
Replies: 4
Views: 164
Posted By thmitch79
I saw that link earlier and followed it except...

I saw that link earlier and followed it except for digging out the pigtail. I did clean the solenoid and the plunger works.
I appreciate the help and will continue looking this weekend when I have...
Forum: Crossovers 10-15-2014, 07:06 PM
Replies: 4
Views: 164
Posted By thmitch79
P0446 code 07 Edge sel

Perfect timing for me but I was going to take the 07 to the shop for my NYS inspection and a OBD code popped up. P0446 Evap system. I checked the gas cap, checked for leaks, finally disconnected the...
Forum: Crossovers 10-10-2014, 03:52 PM
Replies: 2
Views: 216
Posted By thmitch79
I found one at a scrap yard, thanks.

I found one at a scrap yard, thanks.
Forum: Crossovers 09-30-2014, 06:48 PM
Replies: 2
Views: 216
Posted By thmitch79
Edge rim code

Hi, I need to replace one of my rims on my 07 Edge SEL. Where do I find the code for it? The tires are 245 / 60 R 18's. This is the result of a tire installer cross threading and over torqueing the...
Forum: Crossovers 08-24-2013, 08:54 PM
Replies: 80
Views: 24,722
Posted By thmitch79
2 Edge's in the driveway, an '07 SEL AWD and a...

2 Edge's in the driveway, an '07 SEL AWD and a '10 SE FWD that we tow behind the class A. I love the looks, drive and the fact they are the best "snowplows" I have ever had. (Live in Central NY state...
Forum: Crossovers 06-22-2013, 01:12 PM
Replies: 0
Views: 294
Posted By thmitch79
Drive shaft support?

2007 Edge SEL, and the damn thing 'thumps' when moving. Looked underneath and found the drive shaft could be picked up and down. The center support - wasn't supportive. Is this supposed to have a...
Forum: Crossovers 11-11-2012, 07:00 AM
Replies: 13
Views: 1,644
Posted By thmitch79
2 Edges, 07 and 10, 02 F150 5.4L and a '03...

2 Edges, 07 and 10, 02 F150 5.4L and a '03 Southwind Motorhome with a V10 6.8L....all get 5W20 Ford Semi Syn every 7500mi and not a lick of issuses. Oil is clean going in and clean coming out. Just...
Forum: Crossovers 12-05-2010, 09:50 AM
Replies: 4
Views: 814
Posted By thmitch79
Exactly why I do my own as well.

Exactly why I do my own as well.
Forum: Crossovers 11-13-2010, 07:00 AM
Replies: 4
Views: 814
Posted By thmitch79
I change the oil in all three Ford engines in the...

I change the oil in all three Ford engines in the driveway, '02 F150 5.4L, '07 Edge 3.5L and an '03 Fleetwood Southwind that has a Triton V10 in it. I use Motorcraft Syn Blend 5W20 in all of them....
Forum: Crossovers 11-13-2010, 06:53 AM
Replies: 2
Views: 399
Posted By thmitch79
I had the same problem with my '07 Edge SEL,...

I had the same problem with my '07 Edge SEL, battery was bad on mine. Might be your problem as well. I find the Motocraft brand of batteries to not be that reliable. MHO of course. Good luck.
Forum: Crossovers 07-18-2010, 07:10 AM
Replies: 5
Views: 1,814
Posted By thmitch79
Noise found

You are NOT going to believe this. First, Thank you to all that responded, I haven't repiled as I just took a very long trip. Rust was the problem. Being in Upstate New York, that should have been...
Forum: Crossovers 02-21-2010, 03:05 PM
Replies: 5
Views: 1,814
Posted By thmitch79
07 edge, grinding noise, any ideas?

Howdy,
I own an 07 Edge, AWD, 35K mi, had the PTU replaced so that SHOULDN'T be an issue but all of a sudden I have a grinding noise at highway speeds. I replaced front and rear rotors and pads,...
Showing results 1 to 12 of 12

 
Forum Jump
 


All times are GMT -5. The time now is 05:36 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup