Go Back   Ford Truck Enthusiasts Forums > Search Forums
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


Showing results 1 to 1 of 1
Search took 0.01 seconds.
Search: Posts Made By: bleedspurple
Forum: Modular V8 (4.6L, 5.4L) 07-28-2014, 08:57 AM
Replies: 49
Views: 5,806
Posted By bleedspurple
4.6 liter

We have a 2007 with a 4.6 in it. with only 97000 miles on it. plugs are suppose to be for 100,000. We take care of our vehicles. It all of a sudden started running rough. Thought it was a sensor....
Showing results 1 to 1 of 1

 
Forum Jump
 


All times are GMT -5. The time now is 03:28 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup