Go Back   Ford Truck Enthusiasts Forums > Search Forums
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


Showing results 1 to 5 of 5
Search took 0.31 seconds.
Search: Posts Made By: hweiland
Forum: 1947 and Older Ford Trucks 07-01-2013, 12:14 PM
Replies: 127
Views: 17,889
Posted By hweiland
Thanks for the tip. These old trucks are...

Thanks for the tip.

These old trucks are gems!
Forum: 1947 and Older Ford Trucks 07-01-2013, 11:33 AM
Replies: 127
Views: 17,889
Posted By hweiland
Great job! Do you know if that windshield wiper...

Great job!
Do you know if that windshield wiper location at the bottom of the window is original? My '46 truck has a hole above the driver's window that looks like it was the original location for...
Forum: 1997 - 2003 F150 02-18-2009, 09:44 AM
Replies: 22
Views: 9,466
Posted By hweiland
97 F150 Total Instrument Failure

I had the same problem with my '97 F-150. I replaced the GEM and that fixed everything (including the fuel gauge which had always been somewhat erratic). No reprogramming of the new GEM is required...
Forum: 1997 - 2003 F150 02-03-2009, 08:30 AM
Replies: 2
Views: 314
Posted By hweiland
Thanks for the welcome

Thanks for the welcome, KingRanchMan. I've found the FTE to be helpful for several issues I've had with my '97 F-150. Now I'm working on a '46 half ton with a stroker in in. I also have the...
Forum: 1997 - 2003 F150 01-30-2009, 11:04 AM
Replies: 2
Views: 314
Posted By hweiland
'97 F-150 Speedometer Problem Fixed

For a couple of years the speedo on my '97 F-150 would occasionally go erratic, drop to zero and then usually recover and be normal for a month or two. Then two weeks ago all gauges dropped to zero...
Showing results 1 to 5 of 5

 
Forum Jump
 


All times are GMT -5. The time now is 05:04 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup