Go Back   Ford Truck Enthusiasts Forums > Search Forums
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


Showing results 1 to 5 of 5
Search took 0.02 seconds.
Search: Posts Made By: Fordgrl83
Forum: 1997 - 2003 F150 02-15-2014, 09:07 AM
Replies: 5
Views: 7,277
Posted By Fordgrl83
Mine had welded itself to the axle. My axle...

Mine had welded itself to the axle. My axle bracket snapped off. Now I gotta go find a new one. Junk yard scavenger hunt today -_-
Forum: Clutch, Transmission, Differential, Axle & Transfer Case 02-14-2014, 08:21 PM
Replies: 0
Views: 270
Posted By Fordgrl83
front differential actuator

So my husband and I were replacing the actuator located on our front axle when the axle snapped. The piece that snapped still will not come off the actuator. Anyways... I got curious and cracked open...
Forum: Modular V8 (4.6L, 5.4L) 02-14-2014, 03:19 PM
Replies: 7
Views: 413
Posted By Fordgrl83
I have and I replaced the fuel regulator. I...

I have and I replaced the fuel regulator. I changed vacuum hoses near my egr valve also one was collapsed and another had a knife cut in it which makes makes me wonder because I had it in the shop...
Forum: Modular V8 (4.6L, 5.4L) 02-14-2014, 10:16 AM
Replies: 7
Views: 413
Posted By Fordgrl83
performance issues

Not since I had the O2 sensors done.
Forum: Modular V8 (4.6L, 5.4L) 02-14-2014, 08:45 AM
Replies: 7
Views: 413
Posted By Fordgrl83
performance issues

I have a 2001 Ford F150 5.4 ltr 4x4. / My truck was running great. Replaced the fuel filter and it was an avalanche. She wouldn't run above 15 mph and wouldnt turn over. Acted like she wasn't getting...
Showing results 1 to 5 of 5

 
Forum Jump
 


All times are GMT -5. The time now is 12:42 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup