Ford Truck Enthusiasts Forums

Ford Truck Enthusiasts Forums (http://www.ford-trucks.com/forums/index.php)
-   2.6, 2.8, 2.9, 4.0 & SOHC 4.0 V6 (http://www.ford-trucks.com/forums/forum59/)
-   -   Fuel Problem (http://www.ford-trucks.com/forums/1316559-fuel-problem.html)

tansdad 05-25-2014 10:43 AM

Fuel Problem
 
I recently replaced the left valve cover gasket on my 1990 2.9L Ranger and now when I start it the fuel pump does not cycle right when turning the key on. It just keeps running. Any suggestions on what I could have done or knocked loose when reinstalling the valve cover?:'(

xlt4wd90 06-05-2014 01:23 AM

No solution yet?

I would check to see if you pinched or otherwise damaged any wires around the valve cover.

Nancy Highsmith 03-05-2016 07:47 PM

I replaced the fuel pump and still wont start Not sure if it is a relay switch or how to bleend the lines

xlt4wd90 03-06-2016 12:46 PM

There is a relay for the fuel pump, located under the hood in the fuse box. Does the fuel pump run for a couple of seconds when you first turn the key to "ON"? You have to listen for it; the relay will click on and off, and the pump should whirl between the clicks. Repeating this a couple of times should pressurize the lines, so no bleeding is necessary. If it's not doing this, the problem could be the relay or the pump.

You can check for pressure by going to the fuel rail, usually near the front passenger side, and look for the Schrader valve; it's like a tire valve. Carefully stick a screw or nail point against the valve core, and fuel should squirt out. That should confirm that there's pressure building up in the lines.


All times are GMT -5. The time now is 05:37 AM.