Ford Truck Enthusiasts Forums

Ford Truck Enthusiasts Forums (http://www.ford-trucks.com/forums/index.php)
-   1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks (http://www.ford-trucks.com/forums/forum37/)
-   -   What have you done to your truck today? (http://www.ford-trucks.com/forums/1004055-what-have-you-done-to-your-truck-today.html)

6fifty_f1fifty 10-24-2010 03:09 PM

What have you done to your truck today?
 
The guys in the 87-96 forum have one of these, so I thought I would start one too. Play along if you like...

Today I swapped instrument clusters because the only gauge that worked was the ammeter. Here is the damaged ic (minus the ammeter that I took out for the other ic):

http://i663.photobucket.com/albums/u...CIMG0003-1.jpg

closer view of tach connections:

http://i663.photobucket.com/albums/u...CIMG0002-1.jpg

Later I will custom wire my tach so it works (the ic I swapped in had no traces for the tach).

00Boss 10-24-2010 03:12 PM

I saw that thread to. I drove my truck lookin for an open library with no success.

Fordzilla80 10-24-2010 03:13 PM

I hope you used a tach cluster for another 80 truck or you're gonna have a few problems. lol.

Today I took a nice long look at my new Radio bezel, and realized that I really want to redo my headliner and have the seat re-upholstered so my interior will be complete. Oh yea, I need new carpet too.lol.

Fordzilla80 10-24-2010 03:15 PM

Quote:

Originally Posted by 00Boss (Post 9477046)
I saw that thread to. I drove my truck lookin for an open library with no success.

My Library was open today, but their collection sucks. I couldn't find anything on Agriculture for my essay aside from how to take care of your steer and gilts.

6fifty_f1fifty 10-24-2010 03:15 PM

Yep I sure did, I had a cluster from my dd, that I swapped out when I found a tach/trip cluster on a truck in the jy...

Fordzilla80 10-24-2010 03:18 PM

Alright sweet.

I actually have a 1982 Cluster in my truck, but I haven't even played with the lights yet to figure out what I need to switch around and what won't work.

I had an 81 printed circuit on my old 1980 cluster, and all I had to do was swap the turn signal and brake indicators. I'm hoping it will be the same with the 82 cluster.

lgwilson 10-24-2010 04:47 PM

Today? Nothing. I'm at a standstill on my project until I get my headliner and seats back from upholsterer. I did stop to look in the cab and admire the new carpet and newly dyed panels.

okiepc1 10-24-2010 05:47 PM

While the weather is nice getting ready for fall, changed oil & filter, checked antifreeze, tire pressure & new wiper blades.


okiepc1

nolan62 10-24-2010 07:07 PM

Today? I drove my 86 for the first time! It moved today under it's own power for the first time in close to 2 years. It has lots of power as I hoped it would from the rebuilt 300. I just drove around the neighborhood but that's a good first step.

desperado_18_2000 10-24-2010 07:14 PM

While I didn't really do much today due to the weather I did however get a few things done yesterday. I relocated my power outlet from the ashtray to the glove box, and installed my gauges where the ashtray used to be. I also took some rattle can metallic silver paint to my rusty rear bumper and sprayed it, granted it isn't a fix but it does look heaps better than it did before. :-jammin

This is just a buildup to my "build" thread I'm going to be posting in the next few days.

ihateminimumwage 10-24-2010 07:26 PM

Nothing today... But I installed my Hydroboost brake setup yesterday :-D

6fifty_f1fifty 10-24-2010 08:07 PM

Quote:

Originally Posted by nolan62 (Post 9477883)
Today? I drove my 86 for the first time! It moved today under it's own power for the first time in close to 2 years. It has lots of power as I hoped it would from the rebuilt 300. I just drove around the neighborhood but that's a good first step.

Did you put anything non-stock on your 300?

LARIAT 85 10-24-2010 08:14 PM

Today:

I changed out my thermostat housing for a shiny new aluminum one I picked up from CarQuest. I finally got rid of that annoying little leak! :)

I re-routed my spark plug wires just to make it look neater and to keep them separated.

Then, I took some different colored electrical tape and wrapped the ends of my vacuum hoses (a tip I got from 81-F-150-Explorer), just to make it a bit more organized and I can tell at a glance what's what.

TheKirbyMan 10-24-2010 09:16 PM

Yesterday, I changed the filter in my transmission (C6), as well as the pan gasket and trans fluid. Wasn't hard at all. Now it shifts much better and best of all, no more shudder.

Tomorrow I'm going to rotate my front tires and see about figuring out why I'm only getting air out of the defrost vent instead of the dash registers. (I think I pulled something loose from the HVAC controls accidentally).

bghnkinf250 10-24-2010 09:55 PM

Nothing for me today - my truck is still parked at work (driving a work car). I did though take out my GMC...to get down spouts and put them up in the rain to make my wife happy. I wish I had been working on my truck.


All times are GMT -5. The time now is 10:43 AM.

Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.