Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


Patrick Omally is starting off with a positive reputation.

Patrick Omally Patrick Omally is offline

Senior User

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. Eddiec1564
    07-31-2014 08:22 PM - permalink
    Eddiec1564
    As for the engine/mounts, in that old thread. I wound up using the 92 F150 engine and frame mounts into my 89 F250. My friend finaly got another tranny and had it rebuilt. His truck still ran badly(tranny issues) and he gave up on it. I bought it from him and after the 302 ate the cam gear I had to swap engines. Needless to say I got shafted with a munged up rebuilt 300 engine, my friend had the engine rebuilder install a "hotrod cam" and now I have nothing but engine ping under load, I can't go over 55MPH with out pinging it to death depending on gas quality! And that's even with ignition timing set at 4deg BTDC insted of factory 10deg BTDC. I am babying it along(over a year now) till I get the 84 F250 back running or my 85 Caravelle running.
  2. Eddiec1564
    07-31-2014 08:09 PM - permalink
    Eddiec1564
    For some reason I can't send a PM to you. So here goes...


    My 84 had the cranky 1BB feedback EECIV system, it started failing and parts even back in the mid 90's were hard to get and expensive too. I used a 87 truck as parts donor and swapped the manifolds, head,fuel tank(another learning curve about the fuel sending units not compatable with older trucks) and customized the EFI wire harness into the 84 truck.

    Power was little better in the top end but I LOST the off idle bottom end I used while off roading/mudding and towing.
    Fuel economy went down from 16 to 18MPG avg to a flat 13 MPG!!! That pissed me off and I could not get it any better.
    Few years ago in a junk yard I scored the Oppy Dp intake manifold and decided to dump the EFI system which did me Ok execpt for the above issues.

About Me

  • About Patrick Omally
    2 Letter State/Province (use "--" for outside USA/
    la
    Country
    USA
    Make
    Ford
    Model
    F-150
    Year
    1996
    Current Mileage
    Rather not say
    Miles per year
    Rather not say
    Gender
    Male

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 09-17-2014 06:55 PM
  • Join Date: 07-25-2014
  • Referrals: 0

Friends

Showing Friends 1 to 1 of 1


All times are GMT -5. The time now is 05:03 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup