Ford Truck Enthusiasts Forums - View Profile: b4camaro91
 

Go Back   Ford Truck Enthusiasts Forums > Members
Log In 


b4camaro91 is starting off with a positive reputation.

b4camaro91 b4camaro91 is offline

New User

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. a11m1ghty
    03-13-2012 04:52 PM - permalink
    a11m1ghty
    By the way, do you have electrical gremlins? I heard about the Water/winshiled leak that gets the GEM/Fuse box wet? And, have you had any issues with heavy down pours getting your COPS wet?

About Me

  • About b4camaro91
    2 Letter State/Province (use "--" for outside USA/
    oh
    Country
    USA
    Make
    Ford
    Model
    Expedition
    Year
    2003
    Current Mileage
    100,000 - 124,999
    Miles per year
    10,000 - 14,999
    Engine type and displacement
    5.4

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 03-11-2012 10:30 PM
  • Join Date: 11-27-2010
  • Referrals: 0


All times are GMT -5. The time now is 12:49 PM.

 

Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup