Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


Truck451 is new and has a neutral reputation at this point.

Truck451 Truck451 is offline

Junior User

Visitor Messages

Showing Visitor Messages 1 to 3 of 3
  1. Mark Kovalsky
    06-11-2010 05:16 PM - permalink
    Mark Kovalsky
    I believe you are right on both counts. That development happened after I left Ford, so I really don't know the details.

    Mark
  2. Mark Kovalsky
    12-29-2009 07:04 PM - permalink
    Mark Kovalsky
    The Ax4S was used in the Windstar. I don't know why they didn't use the Duratec in the Windstar.
    The Windstar didn't share anything with the Explorer as far as I know.
    The trans with the 460 V8 was the E4OD, not the AODE or the 4R70W.
  3. Mark Kovalsky
    12-27-2009 05:19 PM - permalink
    Mark Kovalsky
    I worked on the AX4S used in the Taurus/Continental/Windstar, then I worked on OBDII for all transmissions, then I worked on the 5R55N in the Lincoln LS, then the TorqShift with the 6.0L, then I worked on transmission cooling, then I left!

    Mark

About Me

  • About Truck451
    2 Letter State/Province (use "--" for outside USA/
    MI
    Country
    USA
    Make
    None - Still Looking
    Model
    None - Still looking
    Year
    None - Still Looking
    Current Mileage
    Rather not say
    Miles per year
    Rather not say

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 12-10-2013 09:24 PM
  • Join Date: 11-09-2009
  • Referrals: 0
This user has not created their gallery.


All times are GMT -5. The time now is 03:27 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup