Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


scott91370 is starting off with a positive reputation.

scott91370 scott91370 is offline

Senior User

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. Kc12345
    04-18-2014 06:54 PM - permalink
    Kc12345
    Hey I'm in a jam and can't figure out this forum how to ask a question so I figured I directly ask you if that's alright with you... I have an 05 escape and it just quit on me on my way to work I was driving and it just died no acceleration no power steering but all lights still on then I pulled over and shut it off when I fired it back up nothing happens just click click and every light shut off not even the anti theft was blinking then I tried to boost it and when I put the red on it sparks like a ****er.. I have checked the starter and all the fuses and even checked the wires going under my floor mat to see if any were broken or corroded its all fine...any other suggestions
    Please help!!
    Thank you
    Kyle

About Me

  • About scott91370
    Location
    Burleson, Tx
    2 Letter State/Province (use "--" for outside USA/
    Tx
    Country
    USA
    Make
    Ford
    Model
    Escape
    Year
    2004
    Current Mileage
    200,000 - 249,999
    Miles per year
    30,000 - 34,999
    Tranny type
    Automatic
  • Signature
    2004 - v6 - 284,500 miles and counting!

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Yesterday 08:59 PM
  • Join Date: 12-30-2008
  • Referrals: 0
This user has not created their gallery.


All times are GMT -5. The time now is 10:14 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup