Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


Bigtony4 is starting off with a positive reputation.

Bigtony4 Bigtony4 is offline

Senior User

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. mustang67
    09-23-2010 11:48 AM - permalink
    mustang67
    Bigtony,
    I was reading your post about 5.4 engine tick. I also had a dealership replace the phasers and continue to get the tick. Are you still running the 15w40 oil, and how is your
    truck running?

About Me

  • About Bigtony4
    2 Letter State/Province (use "--" for outside USA/
    pa
    Country
    us
    Make
    Ford
    Model
    Ranger
    Year
    2004
    Current Mileage
    50,000 - 74,999
    Miles per year
    Rather not say

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 06-15-2012 06:24 PM
  • Join Date: 06-13-2007
  • Referrals: 0

Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 07:34 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup