Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


origcharger has a good reputation on FTE.origcharger has a good reputation on FTE.

origcharger origcharger is offline

Posting Guru

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. 9228.bobcat
    11-29-2009 12:00 PM - permalink
    9228.bobcat
    Hi origcharger, the issue I am having is sometimes when I stomp on the throttle on my 2005 F250 6.0 everything works great and then a few minutes later when I stomp on it the turbo lags for a few seconds and then comes to life but it does this for a few minutes and comes out of it,or if I pull over and shut the truck off it works fine, seems like it resets something electrically and everything works accordingly. I bought the truck wrecked and I am thinking maybe it needs the newest flash. I think the 05' the had a flash for the egr and vgt, not sure though. I really appreciate your help, and any thoughts of what my problem is would be greatly appreciated. Also when the turbo lags the transmission wants to stay in drive a little longer until shifting into O.D. Maybe the ebp?? I don't know. I have put a new egr and cleaned the ebp tube. Thanks again,Eric
  2. rooster09
    03-21-2009 11:28 PM - permalink
    rooster09
    origcharger i want to say thanks for your info on oil changes i have been fighting with my truck for 2 and half weeks and i will do my own oil changes from now on 18 quarts of oil drained out refilled with 14 and truck hasnt missed a lick ford told me it was turbo and wanted 3500.00 glad i didnt do that but what gets me they didnt even check that but yet they charged me 600.00 to check it out. really makes it tough to be a ford lover thanks again for your info Ken

About Me

  • About origcharger
    2 Letter State/Province (use "--" for outside USA/
    Ia
    Country
    USA
    Make
    Ford
    Model
    Econline or E-Series
    Year
    2004
    Current Mileage
    100,000 - 124,999
    Miles per year
    25,000 - 29,999
  • Signature
    2004 E-450 6.0 187,500 miles
    7,500 mile, 15 quart changes, 5W-40 Syn.
    UOAs consist of checking for metal on drain plug magnet. Dyed ULSD fuel with no additives. Never been reflashed. Total parts replaced; one turbo,
    two EGR valves, forgot to reconnect the wires on the second one at 151,360 miles.

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 11-21-2014 04:34 PM
  • Join Date: 06-16-2006
  • Referrals: 0

Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 06:00 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup