Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


bro460 is starting off with a positive reputation.

bro460 bro460 is offline

Senior User

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. UPFord
    03-30-2012 01:44 PM - permalink
    UPFord
    I am wondering if you can tell me where exactly the protective cover and wire are that you mention in your post about fuel pump duty cycle. I am experiencing the same symptoms and cannot find where the issue is. Thank you

About Me

  • About bro460
    2 Letter State/Province (use "--" for outside USA/
    bc
    Country
    canada
    Make
    Ford
    Model
    Bronco
    Year
    1980
    Current Mileage
    125,000 - 149,999
    Miles per year
    1,000 - 4,999

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 04-22-2014 08:47 PM
  • Join Date: 04-09-2006
  • Referrals: 0


All times are GMT -5. The time now is 07:44 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup