Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


optikal illushun is starting off with a positive reputation.

optikal illushun optikal illushun is offline

Postmaster

Visitor Messages

Showing Visitor Messages 1 to 6 of 6
  1. optikal illushun
    05-16-2010 11:53 PM - permalink
    optikal illushun
    i dont remember to be honest but i think it would be there to help seal against the gasket...not sure though.
  2. |WYG|SS
    05-08-2010 03:25 PM - permalink
    |WYG|SS
    hey when you put your headers on did they have a lip on the head flage part like this? if you can see it is raised a little bit, im thinking about grinding it down flush
    Click the image to open in full size.
  3. |WYG|SS
    03-02-2010 05:37 PM - permalink
    |WYG|SS
    if you could post the pics now that would be great cause i wont get to putting the headers on until mid-spring/summer. where did you hook your o2 sensor up to? and do you have a cat. on your exhaust?
  4. 4bo4
    11-11-2009 09:06 PM - permalink
    4bo4
    Hey I saw on your sig tha you have a V8 tb on your 300 and you running the hedman headers. What tb are you running because I have a 351 tb and I wanted to know how it runs with that tb and if the computer can comrpamise and if the injectors hold up or not. DId you have to over obre the intake manifold as well. one other thing how did you set up your EGR valve on your headers?
  5. badas4.9l
    04-23-2009 07:00 AM - permalink
    badas4.9l
    hi i was wondering how well the crane cam part# 503905 works with the efi 300?
  6. blackchr
    04-15-2009 03:21 AM - permalink
    blackchr
    Hi, I'm looking for bigger mirrors for my 89 250, and it looks like you have some on your 88. Can you tell me where they came from, or if they're stock?

About Me

  • About optikal illushun
    Location
    Coal Region
    Interests
    Trucks, Cars, Mobile audio and various other stuff
    2 Letter State/Province (use "--" for outside USA/
    PA
    Country
    USA
    Make
    Ford
    Model
    F-150
    Year
    1993
    Current Mileage
    100,000 - 124,999
    Miles per year
    5,000 - 9,999
    Horsepower
    0
    60 foot time
    0
    1/8 Mile ET
    0
    1/8 Mile MPH
    0
    1/4 Mile ET
    0
    1/4 Mile MPH
    0
  • Signature
    93 F150 XLT 4x4
    Modded 300/Built E4OD/D44 SAS/35"s
    2006 F150 FX4
    5.4/Auto/EXSB/Silver n DSG/Stock
    1988 F350 Custom 4x4
    7.3 IDI NA/ZF/35"s

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 03-30-2014 03:50 PM
  • Join Date: 03-02-2002
  • Referrals: 0

Friends

Showing Friends 1 to 2 of 2

Contact Info

Instant Messaging
Send an Instant Message to optikal illushun Using...
This Page
http://www.ford-trucks.com/forums/member.php?u=30923
Albums In optikal illushun's Gallery

lNemezizUpdated: 07-24-2014
My baby
Views: 346
Vehicle Info: 1993 F150

300Updated: 07-18-2014
Various pics of my 300 and related stuff
Views: 251
Vehicle Info: 1993 F150



All times are GMT -5. The time now is 06:23 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup