Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


mrshorty is gaining momentum as a positive member of FTE.

mrshorty mrshorty is offline

Postmaster

Visitor Messages

Showing Visitor Messages 1 to 4 of 4
  1. knuckleheadrider
    04-19-2012 10:00 AM - permalink
    knuckleheadrider
    mrshorty ... please read my reply to: 1995 Exploder fuel pump problems???


    Thanks, Timm .......

  2. RomerB2
    08-04-2010 03:06 PM - permalink
    RomerB2
    Hey there stranger. Can you check this out and tell me if it looks like I'm on the right track?

    http://www.ford-trucks.com/forums/81...ing-right.html

    You've helped me tons in the past, thanks.
  3. mrshorty
    04-21-2010 12:45 PM - permalink
    mrshorty
    wick972:

    Does the on-line resource have to be free? The only free on-line source I know of for repair information is the free vehicle repair guides at autozone.com They seem to be essentially the same stuff as you'd find in a Chiltons DIY manual.

    If you are willing to pay for it, alldatadiy.com runs a subscription service that, according to others who have subscribed, is pretty comprehensive.

    You might check with your local public library. Depending on demand, some libraries carry a subscription to these sources of repair information which you can access.
  4. wick972
    04-21-2010 11:00 AM - permalink
    wick972
    hey ya Mr Shorty.... i was wondering if you have or know where( on line) i can find a diagram of ou FM146 clutch system. like an exploded view. i'm still baffled about my clutch problem.http://www.ford-trucks.com/forums/84...ii-clutch.html i am 99% sure i have the clutch plate in correct, but then there's this darned DOUBT that it's not.
    thanks,
    Wick972

About Me

  • About mrshorty
    Location
    UT
    Interests
    camping, fishing, geology
    2 Letter State/Province (use "--" for outside USA/
    UT
    Country
    USA
    Make
    Ford
    Model
    Explorer
    Year
    1992
    Current Mileage
    Rather not say
    Miles per year
    Rather not say
    Horsepower
    0
    60 foot time
    0
    1/8 Mile ET
    0
    1/8 Mile MPH
    0
    1/4 Mile ET
    0
    1/4 Mile MPH
    0
  • Signature
    '87 Bronco II XLT 4x4 & '92 Explorer XLT 4x4 & '98 Chev Suburban K1500 SLT 4x4

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 09-20-2012 09:20 PM
  • Join Date: 12-26-2001
  • Referrals: 0
This user has not created their gallery.


All times are GMT -5. The time now is 12:12 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup