Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


fordboy_52 is a splendid one to beholdfordboy_52 is a splendid one to beholdfordboy_52 is a splendid one to beholdfordboy_52 is a splendid one to beholdfordboy_52 is a splendid one to beholdfordboy_52 is a splendid one to beholdfordboy_52 is a splendid one to beholdfordboy_52 is a splendid one to behold

fordboy_52 fordboy_52 is offline

Post Fiend

Visitor Messages

Showing Visitor Messages 1 to 10 of 36
  1. Handyman1355
    11-10-2013 06:13 AM - permalink
    Handyman1355
    Hi Fordboy. I have a question about the 5R55E seperator plate fix. I have a 2001 ford ranger with the 5R55E, 4.0 sohc. In the post for the fix it describes removing a screen and a spring. Is this part of the updated version of the valve body? I ask because some tutorials on this procedure do not mention removing the screen and spring. Thanks Robert
  2. joycben
    04-29-2013 06:52 PM - permalink
    joycben
    Help Someone Please ? Hi : Im Bennie , 54 Years Old I Live In Ocilla Ga !!! Ive Got Some Questions For Anyone Knowing Please !!! I have A 2006 Ford Ranger 2.3 lt 4 cyl . I Purchased It Used 2 Years Ago , It Started Useing Oil A Good While back , Ive Been Keeping The Oil Changed Regularly , But I Can Drive It 100 Miles And Its Done Used 1 To Sometimes 2 Quarts Of Oil , I Put 10W30 In It , I Noticed Its Blowing White Smoke When I First Crank It , With Some Black Soot Sputted Out , Can Anyone Tell me What The Problem Is , Its Got About 124,000 Miles On It !!!!! Ive Used Some Lucus Oil Treetment , Doesnt Help !!! Please Reply Anyone !!!

    Thanks Bennie !!!!!
  3. backwoodskennels
    11-16-2012 09:09 AM - permalink
    backwoodskennels
    I have tried to read the Ranger suto trans problem thread (many posts), but want to make sure I am interpreting correctly. 2000 Ranger 4X4 4.0 5R55E w/149,000 and tranny rebuilt at 112,000, O/D light flash after 3 miles and continues until truck is re-started. Slipping in all gears, with hard shift sometimes, let off accelerator and rpms drop as though in nuetral. No power to wheels in extreme uphill or sandy situations. VBG issue or just crappy rebuild?
  4. Wildpony2000
    09-25-2012 05:50 PM - permalink
    Wildpony2000
    FYI @ Door Lock technical article.
    Its requires an AOL signup & password so I didn't get to read it. Is there some other way to view it?
    I am trying to find out how the lock wires are routed on a 1991 Ranger. I have the colors and diagram.
  5. fordboy_52
    07-31-2011 06:42 PM - permalink
    fordboy_52
    tim, i sold the ranger years ago. nothing new to add
  6. Tim66
    07-30-2011 01:16 PM - permalink
    Tim66
    Matt, I just viewed you repair guide for the 4r55e 5r55e Ranger Auto transmission. Excellent work! Since the article was posted have you had any updates or modifications to the article? Where did you get the diagrams pictured in the article? I plan on attempting this repair on my 2004 Ranger but I want to be fully prepared before I begin. Thanks again for the excellent repair procedure.
    Tim
  7. megawatt00
    11-06-2010 09:56 PM - permalink
    megawatt00
    Thanks for the reps. Some of the stuff in there is to funny,
  8. pawpaw
    10-19-2010 08:29 AM - permalink
    pawpaw
    Ref: Battery Tutorial (link) atop the Ranger & BSeries forum.

    The FTE forums software link seems to be corrupt, as it won't redirect to the page I have typed in the thread & the link I have posted is still up & can be accessed as I have it listed in my post. Car and Deep Cycle Battery FAQ 2010, Battery Manufacturers and Brand Names List, and Battery References and Information Links List

    So something appears to have happened to corupt the redirect link on FTE's end. Can you put a fix on the redirect problem????

    EDIT: when I click on my posted link, I now get a 503 error, File Temporally Unavailable????

    Again this link is still up & working as I have it posted here, from other sites, like TCCA.
  9. fordboy_52
    10-19-2010 06:58 AM - permalink
    fordboy_52
    i dont actually have to word doc anymore. its in the tech area of the ranger forum. (first post)
  10. hawker rider
    10-18-2010 11:15 PM - permalink
    hawker rider
    Hi Matt,

    Could you send me a copy of the valve body gasket replacement that you had for the flashing OD off light in a 99 Explorer?

    That's what's happening to me after driving for a while, not all the time, and it doesn't seem to be going into limp mode after the light starts flashing, just some harder shifts, but no slipping.

    I think that your write up might give me a bigger window of opportunity to shop for a replacement for this oldie.

    Thank you, Mark
    oversteeg@hotmail.com

About Me

  • About fordboy_52
    Biography
    i hate chevy's
    Location
    Abilene Kansas
    2 Letter State/Province (use "--" for outside USA/
    ks
    Country
    usa
    Make
    Ford
    Model
    F-150
    Year
    2000
    Current Mileage
    75,000 - 99,999
    Miles per year
    0 - 999
  • Signature
    Matt - Kansas State University ALUMNI!
    2000 f-150 5.4 triton 4x4

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: 09-18-2014 05:28 PM
  • Join Date: 05-10-2004
  • Referrals: 0

Contact Info

Instant Messaging
Send an Instant Message to fordboy_52 Using...
This Page
http://www.ford-trucks.com/forums/member.php?u=192489


All times are GMT -5. The time now is 03:39 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup