Ford Truck Enthusiasts Forums - View Profile: scott91370



scott91370 is gaining momentum as a positive member of FTE.scott91370 is gaining momentum as a positive member of FTE.

scott91370 scott91370 is offline

Elder User

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. Kc12345
    04-18-2014 07:54 PM - permalink
    Kc12345
    Hey I'm in a jam and can't figure out this forum how to ask a question so I figured I directly ask you if that's alright with you... I have an 05 escape and it just quit on me on my way to work I was driving and it just died no acceleration no power steering but all lights still on then I pulled over and shut it off when I fired it back up nothing happens just click click and every light shut off not even the anti theft was blinking then I tried to boost it and when I put the red on it sparks like a ****er.. I have checked the starter and all the fuses and even checked the wires going under my floor mat to see if any were broken or corroded its all fine...any other suggestions
    Please help!!
    Thank you
    Kyle

About Me

  • About scott91370
    Location
    Burleson, Tx
    2 Letter State/Province (use "--" for outside USA/
    Tx
    Country of Residence
    US
    Make
    Ford
    Model
    Escape
    Year
    2004
    Current Mileage
    200,000 - 249,999
    Miles per year
    30,000 - 34,999
  • Signature
    2004 Tribute - v6 - 297,000 miles and counting!
    2015 F-150 - 3.5 Ecoboost - 11,000 miles

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Yesterday 08:16 PM
  • Join Date: 12-30-2008
  • Referrals: 0

Friends

Showing Friends 1 to 1 of 1

All times are GMT -5. The time now is 10:55 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.