Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


Gitxsan f350 is starting off with a positive reputation.

Gitxsan f350 Gitxsan f350 is offline

New User

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. Gitxsan f350
    04-07-2014 10:44 PM - permalink
    Gitxsan f350
    Hi I'm having an instrument cluster problems it's a 2000 f350 xlt v10 crew cab long box. One day the cluster was working then it stopped working all gauges are dead the lights on the cluster works. if you could help me out it would be much appreciated. Thanks gitxsan f350

About Me

  • About Gitxsan f350
    2 Letter State/Province (use "--" for outside USA/
    --
    Country
    Canada
    Make
    Ford
    Model
    F-350
    Year
    2000
    Current Mileage
    250,000 or more
    Miles per year
    15,000 - 19,999
    Gender
    Male

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 04-23-2014 05:48 PM
  • Join Date: 03-12-2014
  • Referrals: 0


All times are GMT -5. The time now is 09:12 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup