Ford Truck Enthusiasts Forums - View Profile: cheezit

cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.

cheezit cheezit is offline

Post Fiend

Visitor Messages

Showing Visitor Messages 1 to 10 of 280
  1. smallcapguru
    10-06-2016 12:01 PM - permalink
    hey cheezit. been reading but never joined until today. saw your awesome posts a while ago on the 6.0 years ago when you were still posting as a ford tech. i see on your sig file that 2012 was the last year? you get out of it? ford lost a good conscientious tech IMO...unless you opened your own shop?
  2. Big Red trucker
    07-09-2016 09:46 AM - permalink
    Big Red trucker
    Hello i have a 03 f250 6.0... been trouble shooting for 2 months now and have read so many forums and still stumped. Have seen that you have solved many issues with the 6.0.. was curious if i could trouble you for a quick talk. I have 2 months of data and replaced parts. All sensor readings etc. Just need some guidance as im new to diesel. I live in ft.worth texas. If not long distance and maybe have few min to spare. Please give me a ring. 817-209-8748. Thank you
  3. forddiesel956
    05-29-2016 09:15 PM - permalink
    Hello cheezit , I have a 2006 f250 6.0 with a leaking driver side up pipe or y pipe it's confusing to me sorry, I'm for sure its the one thats goes to the right side of the turbo and has a bad leak by the bellows
    I ordered this from sinister Diesel
    Y-Pipes for Ford 6.0L (Raw) (SD-YPIPE-6.0)

    Sinister Diesel Y-Pipes for Ford 6.0L (Raw)

    i should've verified first but hopefully it's right
    Could u please help me verify that's the driver side turbo y pipes?
  4. Kevin McCarty
    04-15-2016 05:05 PM - permalink
    Kevin McCarty
    Hey cheezit i have a problem going on with my 6.0l. Can you PM me and give me a hand when you have time? I got new injectors 2000 miles ago 2 went out on warranty with broken spool valve bolts. The third just went and I think it took cylinder 6 with it. Uneven crank and injector 6 contribution code.
  5. rakovice
    03-20-2016 07:51 PM - permalink
    Hey Cheezit, I read a post on which you had stated that you had the preloaded tunes for the 6.0L with VXFB strategy for X4 7015. Please send me a pm or email at edinrakovic at gmail dot com if still have the files. The error that I get is unsupported vehicle.

    Thank you,
  6. cheezit
    02-10-2016 06:03 PM - permalink
    My best guess is that you may have a vgt solenoid going bad. The only real way to know is swap a knowen good one in.
  7. aegons6.0
    02-10-2016 04:14 PM - permalink
    Hey Cheezit, I disconnected the EBP and drove around for about 35 minutes, 30-65mph, and I used cruise control.

    Cruise control and acceleration through all gears felt smoother.

    Idle at stop signs with break seemed smoother.

    Truck seemed to idle more evenly, it usually winds up like a jet. ( the idle sounded deeper as well)

    It did have a more prominent injector tapping noise though I think? Maybe thats just because the EBP was unplugged.

    Thanks a ton ! let me know what you think .
  8. aegons6.0
    02-09-2016 05:32 PM - permalink
    I also forgot to mention. I've had some surging on acceleration. In case that sheds more light. 10- 4 on the ebp i'll let u know how that goes.
  9. aegons6.0
    02-09-2016 03:11 PM - permalink
    Hey Cheezit A of all thank you for the help back in September (I wound up removing MAP hose to find the Manifold port was clogged with crap) A toothpick down the hole and it was good to go.
    Your insight was a life changer as I was in a predicament and was able to get her fixed.

    I've been driving the truck since and have been experiencing some more abnormalities.
    My truck will stutter/miss/buck back when driving.

    It usually does this when ----
    I'm going up a hill in high gear.
    When I'm cruising @ 55/60 in high gear.
    It stutters when I'm pulling a 5k load on a 16 ft trailer.
    Stutters often with cruise control feature on as well.

    It seems to be better under harder acceleration and a higher speed of 70 mph.
    Thank you sir.
  10. Im confused
    01-19-2016 07:24 PM - permalink
    Im confused
    I have an 06 F-150 crew cab that the Windows will not go up or down from individual doors or main switch on drivers door. BUT you can still lock and unlock from drivers door. I replaced the switch on the drivers door. Still nothing checked fuses, relays, wiring in the drivers door. Also when the truck is off & drivers door open the radio will not shut off automatically but if any other door is opened it will shut off. Any ideas??? Help I'm confused

About Me

  • About cheezit
    17 years as a ford tech also a Senior Master as well as ASE mater and L1
    N. Fort Worth, tx
    2 Letter State/Province (use "--" for outside USA/
    Country of Residence
    Current Mileage
    50,000 - 74,999
    Miles per year
    Rather not say
  • Signature
    Former Ford Senior master tech, gas and diesel.1992-2012
    ASE Master Tech, L1 certified.
    2006 f250 cc swb fx4 6.0
    mods arp,egr delete, tuned, 91 gallon RDS fuel tank.


Total Posts
Visitor Messages
General Information
  • Last Activity: 10-03-2016 09:24 PM
  • Join Date: 10-19-2009
  • Referrals: 1


Showing Friends 1 to 10 of 41

All times are GMT -5. The time now is 10:38 AM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.