Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


rodjwashington is starting off with a positive reputation.

rodjwashington rodjwashington is offline

New User

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. rodjwashington
    02-21-2013 11:22 PM - permalink
    rodjwashington
    On my 57, replacing alot of stuff, Have a 351w HO from 86 F-150, but a HEI distributor. Not too sure how to wire ignition system. Had a generator set-up with resistor of fire wall...Any feed back would be great. Keep it simple-stupid ,LOL

About Me

  • About rodjwashington
    2 Letter State/Province (use "--" for outside USA/
    Tx
    Country
    USA
    Make
    Ford
    Model
    F-100
    Year
    1957
    Current Mileage
    50,000 - 74,999
    Miles per year
    0 - 999

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 03-31-2014 05:30 PM
  • Join Date: 11-25-2011
  • Referrals: 0

Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 01:48 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup