Go Back   Ford Truck Enthusiasts Forums > Members
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!


tbear853 has a good reputation on FTE.tbear853 has a good reputation on FTE.

tbear853 tbear853 is offline

Posting Guru

Visitor Messages

Showing Visitor Messages 1 to 10 of 10
  1. tln
    08-31-2013 01:14 PM - permalink
    tln
    I used the supplied lube that came with the cam.
  2. tln
    08-27-2013 08:24 PM - permalink
    tln
    I put an eldebrock preformer cam in my 351M ran good at startup 15 min into breakin noise started in the valve covers. thought it was odd. Drove it maybe 50 miles and got on it and it started back firing, popping. Pulled valve covers found #1 exhaust really loose, Pulled cam all exhaust lobes except 7 and 8 wiped out. I put new edelbrock valve springs in when I changed the cam. I set them to the correct hight but did not check the pressure. used rotator on exhaust valves. You posted in 2011 a reply to the popping saying it was exhaust valve problem. When I called Edlebrock they said the cam failed because of not putting zinc additive in the oil. I am wondering if something is wrong with the exhaust valve spring tension. I hate to ruin another cam. What do you think? Thanks in advance for your response.
  3. devino246
    06-17-2012 10:11 PM - permalink
    devino246
    Thanks for the reps!
  4. CelticDevilDog
    02-19-2012 05:10 PM - permalink
    CelticDevilDog
    Thanks for the reps.
  5. MCDavis
    11-17-2011 07:00 AM - permalink
    MCDavis
    Les, got you all setup on the map. Thanks for contributing!
  6. MCDavis
    11-11-2011 08:36 AM - permalink
    MCDavis
    Welcome to the Chapter. Glad to have you on board! Don't forget to drop by the forum and say hello.
  7. devino246
    05-26-2011 06:25 PM - permalink
    devino246
    Im somewhat familiar. I was born in Lynchburg, moved down here a good 14 years ago. Ive spent most every other weekend in Campbell County for the last 6 months or so. Actually bought my truck there.
  8. devino246
    05-25-2011 04:22 PM - permalink
    devino246
    Noticed your from the Shenandoah Valley. What part, if you dont mind me asking?
  9. Coskid
    08-21-2010 11:12 PM - permalink
    Coskid
    No I understand man and believe me if there was a way for my wife to be involved with my truck then i would do it but it is not possible. The only reason she was ok with me purchasing the truck is because I am a builder and it comes in handy almost everyday. But thanks again and hope to see you around more.
  10. Coskid
    08-16-2010 01:45 PM - permalink
    Coskid
    That's a good looking truck you have there and thanks again for keeping me in check. I wouldn't of hide something from my wife but its nice that someone you don't even know would look out for you. Its rare to see that these days.

About Me

  • About tbear853
    Location
    Shenandoah Valley
    2 Letter State/Province (use "--" for outside USA/
    Va
    Country
    USA
    Make
    Ford
    Model
    F-150
    Year
    2007
    Current Mileage
    25,000 - 49,999
    Miles per year
    1,000 - 4,999
    Engine type and displacement
    5.4 3v
    Induction
    N/A
    Horsepower
    0
    60 foot time
    0
    1/8 Mile ET
    0
    1/8 Mile MPH
    0
    1/4 Mile ET
    0
    1/4 Mile MPH
    0
  • Signature
    There's 2007 and there's 1977...
    ...
    two good years for trucks ...



    ...
    and whatever you do, Have a Safe Trip!

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: Yesterday 10:33 PM
  • Join Date: 02-09-2004
  • Referrals: 0

Friends

Showing Friends 1 to 4 of 4
Albums In tbear853's Gallery

tbear's '77 4X4 CustomUpdated: 07-07-2014
'77 F-150 4x4 owned since May 86. Was Wimbledon White over Rangoon Red when purchased, I repainted years ago using Toyota Super White and Super Red colors. Gonna re-do this year for sure! Looking at pictures of her when she was in her prime has been an inspiration. You'll see me more at this sight too, looking for help, and helping when I can.
Views: 168
Vehicle Info: 1977 F150

tbear's '07 FX4 FlaresidUpdated: 07-06-2014
A 2007 FX4 Scab Flareside that the wife talked me into buying August 2009 before I retired 01-01-10. Love this truck, we even built a carport primarily to house it. Still have the '77, looks like I'll be keeping it a long time.
Views: 61
Vehicle Info: 2007 F150



All times are GMT -5. The time now is 06:27 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup