Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-24-2010, 10:22 PM
dturnersr's Avatar
dturnersr dturnersr is offline
Senior User
 
Join Date: Aug 2010
Posts: 102
dturnersr is starting off with a positive reputation.
07 Expy...cranks..nostart...then starts??

Okay, my wife's Expy has been starting wierd. It cranks but won't start...if I cycle the key three or four times it fires right up.? I kinda feel like it is an ignition switch concern...not the fuel pump or fuel system...it almost feels like the ignition switch hangs some. No CEL or other concerns...anyone have an similar experience>???? BTW 105K on Exp.
Reply With Quote
  #2  
Old 09-26-2010, 08:04 PM
dturnersr's Avatar
dturnersr dturnersr is offline
Senior User
 
Join Date: Aug 2010
Posts: 102
dturnersr is starting off with a positive reputation.
I really believe this is an ignition switch issue....anyone replace one?
Reply With Quote
  #3  
Old 10-13-2010, 06:28 PM
dturnersr's Avatar
dturnersr dturnersr is offline
Senior User
 
Join Date: Aug 2010
Posts: 102
dturnersr is starting off with a positive reputation.
bump, surely some else has heard or had this problem...
__________________
David's- 1995 F-250 SC 4X4 7.3PSD, E40D, 3.54 Gears, 3" downpipe 4" MRBP, 6637, FPR .177.

1953 F100 a work in progress. 50 year anniversary edition of the F100.

It's not the bad people that concern me, it's the good one's who do nothing about them.
Reply With Quote
  #4  
Old 01-31-2011, 04:49 PM
dturnersr's Avatar
dturnersr dturnersr is offline
Senior User
 
Join Date: Aug 2010
Posts: 102
dturnersr is starting off with a positive reputation.
the answer is-

intermentant open on the fuel pump pressure regulator in the tank. Bad news is you have to replace the whole pump unless you rob on off another pump which....I don't have lying around. Good news is I found it albeit much later, but it required a lot of checking because in the begininng it would kick up the fuel pressure-now it goes to zero quick.
__________________
David's- 1995 F-250 SC 4X4 7.3PSD, E40D, 3.54 Gears, 3" downpipe 4" MRBP, 6637, FPR .177.

1953 F100 a work in progress. 50 year anniversary edition of the F100.

It's not the bad people that concern me, it's the good one's who do nothing about them.
Reply With Quote
Old 01-31-2011, 04:49 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
03, 07, cranks, expedition, expidition, long, start, starts

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 11:54 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup