Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.0L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


6.0L Power Stroke Diesel 2003 - 2007 F250, F350 pickup and F350+ Cab Chassis, 2003 - 2005 Excursion and 2003 - 2009 van SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 09-24-2010, 05:05 PM
TChap6liter's Avatar
TChap6liter TChap6liter is offline
New User
 
Join Date: Sep 2010
Posts: 16
TChap6liter is starting off with a positive reputation.
2003 6.0 missing/idling rough

Ok guys, im having some trouble. I have an 03 powerstroke 6.0, and for some reason it runs really rough. I replaced my ICP sensor and wiring harness then updated my computer and that didn't fix it. I took it to a shop and they told me my #1 and #7 injectors were bad, so i replaced them. no change. When it idles, it acts like it misses, and when you drive it down the road it shakes and misses for about 20 minutes, then it stops. Im not sure what else to do. I stretched my fuel regualtor spring to try and get more pressure but that didn't work either.
Reply With Quote
  #2 (permalink)  
Old 09-24-2010, 07:16 PM
brickie's Avatar
brickie brickie is offline
Postmaster
 
Join Date: Mar 2007
Location: AB/BC
Posts: 3,071
brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.
I had a miss in my 350 a few years back,took it to the dealer(last dealer visit) 2200 bucks later I still had a miss.Dealer was getting injector codes but once replaced with new injectors the code came back.So I replaced 8 injectors with aftermarket and low and behold I still got a GD miss.I posted here about my trouble and either Blackhat or Bow Tie Hater Told me it was the HPO rail check valve, so I swap them out and the miss is gone never to return.
__________________
03/04 6.0L 350 Crew ,DRW,ZF-6, XLT fx4, EconoMax injectors, Autometer Fuel, Boost & EGT. Fass 95/90, Sct X-III with some sweet Spartan tunes, ARP studs, RR fuel system, Southbend FB8, Fluiddamper, Ali Arc hunting bumper,Light Force, Ride-Rite helpers,Ford APCM and some other stuff.
03 6.0L Ex LTD mostly stock,05 6.0 CC srw SB, 95 f250 4x4 woods truck, 68 f100 project
Reply With Quote
  #3 (permalink)  
Old 09-24-2010, 11:52 PM
TChap6liter's Avatar
TChap6liter TChap6liter is offline
New User
 
Join Date: Sep 2010
Posts: 16
TChap6liter is starting off with a positive reputation.
Thanks man. sure hope that does the trick. how much does that check valve run? And how hard is it to change? Is there one on each side of the engine or just one for both sids?
Reply With Quote
  #4 (permalink)  
Old 09-25-2010, 12:47 AM
brickie's Avatar
brickie brickie is offline
Postmaster
 
Join Date: Mar 2007
Location: AB/BC
Posts: 3,071
brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.
One on each oil rail I think they were about 60 bucks each.It isn't a difficult job if you have been under the valve covers before. Page 40: Fuel Management System
__________________
03/04 6.0L 350 Crew ,DRW,ZF-6, XLT fx4, EconoMax injectors, Autometer Fuel, Boost & EGT. Fass 95/90, Sct X-III with some sweet Spartan tunes, ARP studs, RR fuel system, Southbend FB8, Fluiddamper, Ali Arc hunting bumper,Light Force, Ride-Rite helpers,Ford APCM and some other stuff.
03 6.0L Ex LTD mostly stock,05 6.0 CC srw SB, 95 f250 4x4 woods truck, 68 f100 project
Reply With Quote
  #5 (permalink)  
Old 09-25-2010, 09:28 AM
TChap6liter's Avatar
TChap6liter TChap6liter is offline
New User
 
Join Date: Sep 2010
Posts: 16
TChap6liter is starting off with a positive reputation.
Ok Thanks. Yeah, I have had the valve covers off before when i changed my injectors, but I never thought about it being in my HPO system. I sure hope this does the trick. I'll be sure to let you know how it does.
Reply With Quote
  #6 (permalink)  
Old 09-25-2010, 10:29 AM
brickie's Avatar
brickie brickie is offline
Postmaster
 
Join Date: Mar 2007
Location: AB/BC
Posts: 3,071
brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.
I hope it does the trick as well as it did for me.
__________________
03/04 6.0L 350 Crew ,DRW,ZF-6, XLT fx4, EconoMax injectors, Autometer Fuel, Boost & EGT. Fass 95/90, Sct X-III with some sweet Spartan tunes, ARP studs, RR fuel system, Southbend FB8, Fluiddamper, Ali Arc hunting bumper,Light Force, Ride-Rite helpers,Ford APCM and some other stuff.
03 6.0L Ex LTD mostly stock,05 6.0 CC srw SB, 95 f250 4x4 woods truck, 68 f100 project
Reply With Quote
  #7 (permalink)  
Old 09-27-2010, 11:50 PM
TChap6liter's Avatar
TChap6liter TChap6liter is offline
New User
 
Join Date: Sep 2010
Posts: 16
TChap6liter is starting off with a positive reputation.
OK so I called my local ford dealer today and told them that I needed a high pressure oil rail check valve and they couldn't figure out what I was talking about. I had to go to them with the picture and show them and the said it was called an oil fitting on their computer. It was $65+tax. It will be in tomorow morning, so tomorow afternoon I will pull it apart and change it out. Hopefully this will fix my missing problem. I'll be sure to keep you posted.
Reply With Quote
  #8 (permalink)  
Old 09-28-2010, 12:16 AM
brickie's Avatar
brickie brickie is offline
Postmaster
 
Join Date: Mar 2007
Location: AB/BC
Posts: 3,071
brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.
Quote:
Originally Posted by TChap6liter View Post
OK so I called my local ford dealer today and told them that I needed a high pressure oil rail check valve and they couldn't figure out what I was talking about. I had to go to them with the picture and show them and the said it was called an oil fitting on their computer. It was $65+tax. It will be in tomorow morning, so tomorow afternoon I will pull it apart and change it out. Hopefully this will fix my missing problem. I'll be sure to keep you posted.
That's funny,I had to show the dealer parts guy the part on his computer screen when I went in as well,
__________________
03/04 6.0L 350 Crew ,DRW,ZF-6, XLT fx4, EconoMax injectors, Autometer Fuel, Boost & EGT. Fass 95/90, Sct X-III with some sweet Spartan tunes, ARP studs, RR fuel system, Southbend FB8, Fluiddamper, Ali Arc hunting bumper,Light Force, Ride-Rite helpers,Ford APCM and some other stuff.
03 6.0L Ex LTD mostly stock,05 6.0 CC srw SB, 95 f250 4x4 woods truck, 68 f100 project
Reply With Quote
  #9 (permalink)  
Old 09-28-2010, 04:10 PM
TChap6liter's Avatar
TChap6liter TChap6liter is offline
New User
 
Join Date: Sep 2010
Posts: 16
TChap6liter is starting off with a positive reputation.
Hey did you change the part or did somebody else?
Reply With Quote
  #10 (permalink)  
Old 09-28-2010, 05:15 PM
gearloose1 gearloose1 is offline
Post Fiend
 
Join Date: Jul 2005
Posts: 6,127
gearloose1 has a good reputation on FTE.gearloose1 has a good reputation on FTE.gearloose1 has a good reputation on FTE.
IF that doesn't fix the problem... PM me and let me think of something else.
Reply With Quote
  #11 (permalink)  
Old 09-28-2010, 07:48 PM
brickie's Avatar
brickie brickie is offline
Postmaster
 
Join Date: Mar 2007
Location: AB/BC
Posts: 3,071
brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.brickie has a spectacular reputation.
I did them myself.
__________________
03/04 6.0L 350 Crew ,DRW,ZF-6, XLT fx4, EconoMax injectors, Autometer Fuel, Boost & EGT. Fass 95/90, Sct X-III with some sweet Spartan tunes, ARP studs, RR fuel system, Southbend FB8, Fluiddamper, Ali Arc hunting bumper,Light Force, Ride-Rite helpers,Ford APCM and some other stuff.
03 6.0L Ex LTD mostly stock,05 6.0 CC srw SB, 95 f250 4x4 woods truck, 68 f100 project
Reply With Quote
  #12 (permalink)  
Old 09-28-2010, 08:59 PM
TChap6liter's Avatar
TChap6liter TChap6liter is offline
New User
 
Join Date: Sep 2010
Posts: 16
TChap6liter is starting off with a positive reputation.
Well how did you get the high pressure oil line off of the fitting? It calls for a special tool but is there a way around it?
Reply With Quote
  #13 (permalink)  
Old 09-28-2010, 11:48 PM
Fallguy2004's Avatar
Fallguy2004 Fallguy2004 is offline
Senior User
 
Join Date: Jan 2005
Location: Alberta, Canada
Posts: 367
Fallguy2004 is starting off with a positive reputation.
Quote from Cheezit, when he answered my same question.

"use a 1/2 collet wrench. the one from my diegrinder works great."



And P.S. it works very well!!!
__________________
2003 F-350 Lariat Crew Cab 4X4 6.0L. RCD EGR Delete, ARP Studs, Banjo Bolt, Red Head Steering Box, ScanGaugeII, Glo Shift Gauges, High Idle Mod, CompuStar.
2005 F150 XLT SuperCrew 4X4.
*UPS has to stop over charging for brokerage!!*
Reply With Quote
  #14 (permalink)  
Old 09-29-2010, 01:54 PM
TChap6liter's Avatar
TChap6liter TChap6liter is offline
New User
 
Join Date: Sep 2010
Posts: 16
TChap6liter is starting off with a positive reputation.
Ok am I doing something wrong?? Should the fitting just pry off? Because I can't seem to get it off no matter what I try...
Reply With Quote
  #15 (permalink)  
Old 09-29-2010, 01:57 PM
TChap6liter's Avatar
TChap6liter TChap6liter is offline
New User
 
Join Date: Sep 2010
Posts: 16
TChap6liter is starting off with a positive reputation.
Quote:
Originally Posted by TChap6liter View Post
Ok am I doing something wrong?? Should the fitting just pry off? Because I can't seem to get it off no matter what I try...
I'm talking about the connector on top of the fitting, not the part that threads into the oil rail
Reply With Quote
Old 09-29-2010, 01:57 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.0L Power Stroke Diesel

Tags
1994, 2003, 2005, 60, arowstar, diesel, f350, ford, idoling, missing, powerstroke, ride, rite, van, vin

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 10:50 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup