Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 09-06-2010, 12:26 PM
Tammommy Tammommy is offline
New User
 
Join Date: Sep 2010
Location: LI
Posts: 7
Tammommy is starting off with a positive reputation.
Poor bass quality in 2010 Expy EL

Hi All,

I'm new to the forum and my primary focus is to try and figure out our stereo problem.

We just picked up our 2010 Limited EL and the sound compaired to our 2007 Limited EL is really poor. No bass, well barely any.

My husband opened up the back and the bass enclosure, amp and speaker are exactly the same (or they appear to be). He did the tech speaker test and they all appear to be working correctly. The only thing that seems to be different is the HU. We have the Sync Nav HU with the DVD player in the back. (All the same stuff as our 2007 except SYNC)

Has anyone else experienced the sound quality difference?
If so, do you know the cause and possible solution?

Thanks for any help,
Tammy
Reply With Quote
  #2 (permalink)  
Old 09-06-2010, 03:19 PM
David1986 David1986 is offline
Senior User
 
Join Date: Jan 2010
Posts: 209
David1986 is starting off with a positive reputation.
My 2010 Exp Limited sounds Great! Have you set you equalizer to the exact same settings that you had in your 2007 model? When we bought our 2010 I had to adjust the EQ to get the sound that I was looking for. The factory setting had the bass turned to standard settings.

Just my $.02.
__________________
David

2011 F150 Platinum 4x4 -
2010 Expedition Limited - Sold
2010 F350 Reg Cab XLT - Sold
Reply With Quote
  #3 (permalink)  
Old 09-06-2010, 03:25 PM
Tammommy Tammommy is offline
New User
 
Join Date: Sep 2010
Location: LI
Posts: 7
Tammommy is starting off with a positive reputation.
Thanks for the reply...
I have the Sync/NAV radio and saw the eq on it, but didn't see where you would adjust the eq.
Can you direct me please?
I hope this is the fix we're looking for!
Tammy
Reply With Quote
  #4 (permalink)  
Old 09-06-2010, 04:11 PM
glruff's Avatar
glruff glruff is offline
Super Moderator
 
Join Date: Aug 2006
Location: DELAWARE, The First State
Posts: 44,273
glruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputation
Got the same Expy Limited you have. The adjustments are thru the touch screen. Have you gone thru the setup yet?
__________________
George, FTE Chapters Moderator - FTE GUIDELINES
05 F250 6.0 FX4, Innovative Diesel Tunes/10 Expedition EL LTD/12 Explorer LTD EB/13 Platinum F150 EB W/Suspension upgrade: Torklift International StableLoads

I AM TOTALLY EXHAUSTIPATED!
Reply With Quote
  #5 (permalink)  
Old 09-06-2010, 05:08 PM
Tammommy Tammommy is offline
New User
 
Join Date: Sep 2010
Location: LI
Posts: 7
Tammommy is starting off with a positive reputation.
I'm not sure about the set up because we picked up the truck from the dealer and the sat radio was already working, but we see that you can adjust the eq ("the visual" eq looking thing in the sounds button section) with the bass/treble only. It doesn't allow us to make any other changes.

My '07 had a really great bass sound and this one is much less hard hitting and the treble is way too high.

We were wondering if there is some kind of a bass inhibitor setting in the radio, as this one is adifferent radio than the '07.
Reply With Quote
  #6 (permalink)  
Old 09-06-2010, 05:26 PM
glruff's Avatar
glruff glruff is offline
Super Moderator
 
Join Date: Aug 2006
Location: DELAWARE, The First State
Posts: 44,273
glruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputation
Not that I know of, mine works great also.

Maybe a trip back to the dealer can get you some help.

I would have to go look, but do you have the rear speakers turned on? Sounds dumb I know, but I didn't get good sound until I went thru the settings, one of which was to turn on the rear. lol
__________________
George, FTE Chapters Moderator - FTE GUIDELINES
05 F250 6.0 FX4, Innovative Diesel Tunes/10 Expedition EL LTD/12 Explorer LTD EB/13 Platinum F150 EB W/Suspension upgrade: Torklift International StableLoads

I AM TOTALLY EXHAUSTIPATED!
Reply With Quote
  #7 (permalink)  
Old 09-06-2010, 05:32 PM
Tammommy Tammommy is offline
New User
 
Join Date: Sep 2010
Location: LI
Posts: 7
Tammommy is starting off with a positive reputation.
Where did you do the set up? Is it something I can redo?

All of the speakers are producing sound, but it just seems like the speakers are producing a much better sound than the sub and it doesn't vibrate (hit hard) the way my other one did.
Reply With Quote
  #8 (permalink)  
Old 09-06-2010, 05:42 PM
glruff's Avatar
glruff glruff is offline
Super Moderator
 
Join Date: Aug 2006
Location: DELAWARE, The First State
Posts: 44,273
glruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputation
Check pages 86 and 87 in your manual.
http://www.motorcraftservice.com/pub.../10ngnsn2e.pdf

Access the Sound menu on the main hu.
__________________
George, FTE Chapters Moderator - FTE GUIDELINES
05 F250 6.0 FX4, Innovative Diesel Tunes/10 Expedition EL LTD/12 Explorer LTD EB/13 Platinum F150 EB W/Suspension upgrade: Torklift International StableLoads

I AM TOTALLY EXHAUSTIPATED!
Reply With Quote
  #9 (permalink)  
Old 09-06-2010, 06:37 PM
Tammommy Tammommy is offline
New User
 
Join Date: Sep 2010
Location: LI
Posts: 7
Tammommy is starting off with a positive reputation.
Yeah, we've gone to the sounds button. It only lets you adjust the bass and treble, not access the eq (like a real eq) to adjust the highs, lows, mids, etc.
Thanks for trying though.
My husband thinks it might be some factory settings in the HU that are regulating the sounds.
Reply With Quote
  #10 (permalink)  
Old 09-06-2010, 06:50 PM
glruff's Avatar
glruff glruff is offline
Super Moderator
 
Join Date: Aug 2006
Location: DELAWARE, The First State
Posts: 44,273
glruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputation
OK, sorry couldn't be of more help.

If you go back to dealer, post back the results.
__________________
George, FTE Chapters Moderator - FTE GUIDELINES
05 F250 6.0 FX4, Innovative Diesel Tunes/10 Expedition EL LTD/12 Explorer LTD EB/13 Platinum F150 EB W/Suspension upgrade: Torklift International StableLoads

I AM TOTALLY EXHAUSTIPATED!
Reply With Quote
  #11 (permalink)  
Old 09-06-2010, 07:03 PM
Tammommy Tammommy is offline
New User
 
Join Date: Sep 2010
Location: LI
Posts: 7
Tammommy is starting off with a positive reputation.
If we can't find any other help with this issue than we WILL be going back to the dealer.

I think we'll go there just to listen to another truck and see if it sounds any different (to rule out ours being broken).

Most people prob wouldn't have an issue with the sound system, because for the most part it sounds good. My husband used to install custom systems for a living, a million years ago, so we're a little picky. The '07 just happened to have an amazing stock system, one of the best we've heard out of the box.

Thanks again for your help and I will post the findings, if we get any .
Reply With Quote
  #12 (permalink)  
Old 09-06-2010, 07:07 PM
glruff's Avatar
glruff glruff is offline
Super Moderator
 
Join Date: Aug 2006
Location: DELAWARE, The First State
Posts: 44,273
glruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputation
Great, btw welcome to FTE!

Check out the local NY chapter and introduce yourself here,,, New York Chapter - Ford Truck Enthusiasts Forums
__________________
George, FTE Chapters Moderator - FTE GUIDELINES
05 F250 6.0 FX4, Innovative Diesel Tunes/10 Expedition EL LTD/12 Explorer LTD EB/13 Platinum F150 EB W/Suspension upgrade: Torklift International StableLoads

I AM TOTALLY EXHAUSTIPATED!
Reply With Quote
Old 09-06-2010, 07:07 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
2010, 2010expypdf, bass, eq, expedition, f150, ford, poor, quality, radio, treble, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 10:20 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup