Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 08-18-2010, 01:55 PM
lincolnfan lincolnfan is offline
New User
 
Join Date: Aug 2010
Posts: 6
lincolnfan is starting off with a positive reputation.
07 NAV A/C and power liftgate problems

I have two issues; 1. My power lift gate will not open/close when using the FOB or the console control. I have to push it shut in order for it to latch. It does not do this all the time. I have read it could be a low battery or control module. 2. When cleaning the floor the other day, I noticed that under the mat, in the front passenger side, the floor was soaked! It seems to be coming from the front of the vehicle. Any ideas? I just finished a long road trip, 15 hours one-way, where the A/C was running most of the time.
Reply With Quote
  #2 (permalink)  
Old 08-18-2010, 04:17 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Search these forums. One user, Expy Bob I think had the leaking ac like you have and I posted a TSB on the rear hatch, but I can't find it now.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #3 (permalink)  
Old 08-18-2010, 04:23 PM
function12's Avatar
function12 function12 is offline
Senior User
 
Join Date: Jan 2002
Location: houston
Posts: 496
function12 is starting off with a positive reputation.
Could be a clogged A/C drain line.
__________________
See ya,
Eric
Reply With Quote
  #4 (permalink)  
Old 08-18-2010, 04:29 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Note to moderators: it's sad when you have to use Google to search these forums becuase the search engine is so poor.

Here you go.
http://www.ford-trucks.com/forums/75...ide-floor.html

My 2008 Ford Expedition Limited ownership experience, maintenance, defects, add-ons, service tips and more
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #5 (permalink)  
Old 08-18-2010, 07:04 PM
lincolnfan lincolnfan is offline
New User
 
Join Date: Aug 2010
Posts: 6
lincolnfan is starting off with a positive reputation.
Thumbs up thanks

Thanks for the help. I will look further into the problem...
Reply With Quote
  #6 (permalink)  
Old 08-19-2010, 02:59 PM
lincolnfan lincolnfan is offline
New User
 
Join Date: Aug 2010
Posts: 6
lincolnfan is starting off with a positive reputation.
more info

Spoke with the Ford/Lincoln service Dept. about my problem. They stated they have never heard of a hush panel. They acknowledged there is a problem with the AC condensor however, just never heard of this panel. More investigating to do!
Reply With Quote
  #7 (permalink)  
Old 08-19-2010, 03:15 PM
lincolnfan lincolnfan is offline
New User
 
Join Date: Aug 2010
Posts: 6
lincolnfan is starting off with a positive reputation.
i was on the Ford website looking for this part and cannot find it; is there another part #? Where is the part number from that is listed...Hush Panel part number
7L7Z-78046A24-A
List price $35.94
Cannot find it anywhere..
Reply With Quote
  #8 (permalink)  
Old 08-19-2010, 10:29 PM
st381 st381 is offline
Junior User
 
Join Date: May 2010
Posts: 73
st381 is starting off with a positive reputation.
The panel is meant for a 08 Lincoln Navigator so it won't be listed under Ford parts. The Baumbach thread should have links to part numbers, etc. Just google Baumback Expedition and it should bring up his website with all his mods and probs with his expy.
Reply With Quote
  #9 (permalink)  
Old 08-20-2010, 10:54 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Email Baumbach and ask him if his still leaks, what he did, etc.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
Old 08-20-2010, 10:54 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
2004, 2010, ac, expedition, ford, gate, hush, lift, liftgate, liftgatewill, open, panel, power, problems, trouble

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 01:10 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup